NPM 2023.1.0 Upgrade Feedback Thread

I pulled the trigger and updated to 2023.1.0. from 2022.4 last week.

Updated a single polling engine with NPM & NTA that monitors 400 nodes.

Install went smooth using the My Deployment - Updates Wizard.

haven't seen any issues over the last week I believe that is related to update.

how did you install go, did you get an issues you logged with support, if so what are the ticket numbers?

  • We are waiting for the GA, but hoping when we do upgrade that it fixes some annoying little issues. For eg 2022.4.x has broken a number of our modern dashboards as it doesn't run the code correctly!

  • FormerMember

    I was forced into 2023.1.0 due to a SqlExpress issue when trying to upgrade Orion HF5, NPM HF3: 2020.2.6 - to 2022.4. Failed (3) time at 80% of the Uninstallation Running with the same error. Error during deleting file: batchparser.dll. Access to path is denied.  Support was useless, as their only advise were document links that didn't work.  Any how - This version is working pretty much as the last one I had.  We are small - less than 200 nodes.  My only issue I've been working on is - I have 2 Disks on 2 servers, both 100GB and 1 is at usage of 84% showing Yellow and the other is 87% showing Green.  Which doesn't make sense.  Short of that it's not too bad.

  • How did you get past those errors messages?  When I see access denied I am wondering if the old version was still running so it couldn't remove it.  Did you manually stop all Solarwinds services?

    As far as the disks showing different statuses, have you customized the thresholds for the servers or types of disk it is?

  • Tried the install via the My Deployments - Updates Wizard. Got to 95% and things slowed down progress bar got to 97% after 15mins and then the installation failed with the error...

    "Database configuration failed: Error while executing script- Cannot insert the value NULL into column 'Id', table 'NetPerfMon.dbo.CLM_CloudJobSettings'; column does not allow nulls. INSERT fails. The statement has been terminated."

    I was upgrading from 2022.4.0

  • Found the SQL commands failing in the ConfigurationWizard.Log file and ran them manually in SQL Management Studio. They worked fine so not sure why they failed during the above install. Deleted the CLM_CloudJobSettings table and ran the Configuration Wizard manually. This time the database configuration completed fine. The Configuration Wizard went on to finish fine on my primary polling engine.

  • The installation then failed on my Additional Poller: 

    "Error 1303. The installer has insufficient privileges to access this directory: C:\Program Files (x86)\SolarWinds\Orion\Erlang\\erts-\bin. The installation cannot continue. Log on as administrator or contact your system administrator.
    MSI (s) (9C:44) [05:29:58:666]: Product: SolarWinds Platform -- Error 1303. The installer has insufficient privileges to access this directory: C:\Program Files (x86)\SolarWinds\Orion\Erlang\\erts-\bin. The installation cannot continue. Log on as administrator or contact your system administrator."

  • My Deployment now shows additional poller as unreachable so won't allow me to attempt to download the offline installer for 2023.1. No download available via Customer Portal so have had to log a support ticket.

  • 2023.1 RC does not look to have included a fix for Web Reports where the column width radio box for "Automatic" or "Custom" isn't populated and the orange line allowing easy adjustment of the column widths still isn't there. This broke after upgrading to 2022.3 and has been confirmed as a known bug by the Solarwinds DEV Team.

  • Can you share the ticket number on the inability to upgrade your poller? 

    Note the previous error you saw about inserting NULL into column "id" was fixed in the GA release of 2023.1 (GA now). 

  • I'm glad to see 2023.1 is released as a GA now.  We upgraded our QA instance to 2022.3.1.  We had some issues with the install and had to do a great deal of it manually and had to reinstall the software on several hosts.  After talking with support they confirmed that they had a lot of support calls on 2022.x versions.  There was also a bug with Solarwinds maps on 2022.4.1 that was reported.  I'm going to upgrade our QA instance very soon to 2023.1.  We are planning to upgrade our prod instance in Q2.  I will certainly give some feedback on our experience.  We have been running 2020.2.5 in prod now and for the most part it has been stable.