Error with Infragistics2.WebUI.Shared.v7.1, Version=7.1.20071.10

When opening user/account page from within NPM I'm getting following error

Could not load file or assembly 'Infragistics2.WebUI.Shared.v7.1, Version=7.1.20071.1050, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb' or one of its dependencies. The system cannot find the file specified. (C:\InetPub\SolarWinds\orion\voip\web.config line 67)

Checked mentioned file and there is reference to 7.1 version of Infragistics2 components but in %windir%\assembly only 7.3 and 8.2 exist.

Any help???

  • Since PublicKeyToken is the same for all versions I just modified C:\InetPub\SolarWinds\Orion\Voip\web.config (lines 67-70)

     

    replace

            <add assembly="Infragistics2.WebUI.Shared.v7.1, Version=7.1.20071.1050, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>
            <add assembly="Infragistics2.WebUI.UltraWebChart.v7.1, Version=7.1.20071.1050, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>
            <add assembly="Infragistics2.WebUI.UltraWebGauge.v7.1, Version=7.1.20071.1050, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>
            <add assembly="Infragistics2.WebUI.UltraWebNavigator.v7.1, Version=7.1.20071.1050, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>

    with

            <add assembly="Infragistics2.WebUI.Shared.v8.2, Version=8.2.20082.1000, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>
            <add assembly="Infragistics2.WebUI.UltraWebChart.v8.2, Version=8.2.20082.1000, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>
            <add assembly="Infragistics2.WebUI.UltraWebGauge.v8.2, Version=8.2.20082.1000, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>
            <add assembly="Infragistics2.WebUI.UltraWebNavigator.v8.2, Version=8.2.20082.1000, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB"/>

    and page is displaying correctly now.

  • Were you upgrading from 2.0 to 2.1?

  • I wasn't upgrading, just installed latest versions (maybe applied Service Packs), and have VoIP Monitor 2.0 atm.

  • Hello Team,

    I am getting similar error while adding nodes, kindly advice

    Could not load file or assembly 'Infragistics2.WebUI.Shared.v8.2, Version=8.2.20082.1000, Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb' or one of its dependencies. The system cannot find the file specified.

  • Relying to this in 2020 as we were getting this almost exact same error when using the 2020.2.1 HF2 offline installer. We ended up having to work with our firewall team to grant the server access to solarwinds.com. As soon as that access was granted, the installer completed without issue. We'd been fighting it for two days and no combination of installing .net3.5, .net4.8, vs 2008,2012,2013,2015, etc would allow the installer to advance past this error. We tried installing single modules (only NPM, SAM, IPAM, or NCM) and it always failed at the same step.

    Hopefully this helps someone else that is getting this Infragistics2 error message now.