Offline installer & pending administrator service update

First time using the offline installer (from 2020.2.4 to 20202.2.5) as we recently went to an offline environment for SolarWinds, hoping some of you with experience using the offline installer can chime in.   Running the pre-flight check  shows a pending update for the SW administrator service which prevents me from running the update. The link states the administrator service MSI is available at downloads.solarwinds.com/.../AdministrationService.msi, however when I attempt to reach that link I get messages stating the site is unavailable.

So, the questions:

how do I get the administrator service updated in order to proceed with the offline upgrade? 

Are there any other "gotcha's" to look out for when running an offline upgrade on an offline environment?

thanks!

Bill

  • If you have HA in your Orion environment, you need to run the upgrade on your active server. Otherwise, it will simply let you know that your is already up to date but it is not.

    For the Administration service, have you closed any running SW application on the server (i.e. Service Manager, trap viewer, etc...)? (also check if another user's logged in). Once done, run the pre-flight check again.

    Kinda weird that you are being asked to update something for the upgrade, unless the actual service is not at 2020.2.4. Do you see "SolarWinds Administration Service - [VERSION HERE]" in your installed programs (Control Panel / Programs and Features)?

  • When running the offline installer you should be presented with two options. Upgrade Now, or Pre-Stage Installation Files.  

    The message you are receiving does not make sense for “Upgrade Now” as the Administration Service is upgraded during the upgrade itself. For “Pre-stage installation files”, the Administration Service is actually upgraded immediately within the “pre-staging” step.

    The link in the message does appear to be outdated. I've notified engineering to take a look. In the meantime the following URL...

    https://downloads.solarwinds.com/solarwinds/CatalogResources/SWA/2020.2/2020.2.5.262/AdministrationService.msi

    Should be the one below for 2020.2.5.

    https://downloads.solarwinds.com/solarwinds/CatalogResources/SWA/2020.2.5/2020.2.5.262/AdministrationService.msi

  • I experience this quite often when doing the pre-stage first, and then continue via the web-interface.

    Some times the administration service fails to upgrade, and it's still on the previous version after running pre-stage. Or it removed the old version but does not install the new one. Both has happened to me during the last few updates at least. It still says pre-stage completed, because the SWA-upgrade is triggered after the pre-stage-completed message is displayed, and it apparently has no check for the SWA-upgrade.
    The fix is simple though. I run the SWA msi-file from the SubInstallers folder in the ISO-file, before continuing via the web-interface.

  • Hi,

    In our environment also faced the same error. You can find the SolarWinds administration service.msi file in subinstaller folder.

    Install the administration service and then try prechecks.

  • You are correct that this error can occur when pre-staging. In some very rare situations for unknown reasons, the upgrade of the Administration Service can fail, resulting in this error. If you or anyone else encounters this issue, please generate a diagnostic and open a support case so that our development team can determine the cause. 

    Please also reference this thread when opening the case