HA installation error

After applying the hotfix, HA deployment never got back, Support have been trying for almost a month.

HA licenses keeps as 'not assigned'. 

When trying to setup 'High Availability Pool' regardless the options the message is

"Cannot create the HA pool. A pool must have both active and standby members"

I have tried editing OrionServers, HA_PoolMembers and engines tables and same outcome or no outcome (if deleting second entry in HA_PoolMembers). tried to validated against a old DB backup instance

Running out of amno

  • I had a similar problem when upgrading to 2020.4 and the only way i was able to fix it was to uninstall all Solarwinds software from secondary/pasive servers, delete all entries of these servers from DB and delete all records of HA.

    Also just to be sure i deleted the HA pool VIP ip from all servers ( it creates a virtual NIC on each server).

    Next step was a repair of the HA service on the main server. I then deleted the HA licenses and after 30 minutes activated them again. 

    After all of this it finally allowed me to reinstall the scalability engine for the main server and i was able to create a new HA pool.