I'm confused about the pre-stage feature (currently on 2020.2.5)

I've run the offline installer which copied over files to my main polling engine and then the offline installer provided a link to My Orion Deployment which offered up a pre-stage button. I clicked that button which brought me to the screen below. I see nothing with respect to pre-stage and I am interpreting the below to mean that it would actually perform the upgrade (instead of pre-staging files).  Please help.  I'd really like to pre-stage all of my additional polling engines. I did put in a support ticket but they have stated that the pre-stage only copies files to the main polling engine not the APE's but the documentation i have read leads me to believe otherwise. Please help!

  • This is what i have learned from the resources i am talking to:

    ONLINE installer - will pre-stage the main and additional polling engines.

    OFFLINE installer - will only pre-stage the main polling engine. At upgrade time the files will be copied over from main to APE's as part of the Centralized Upgrade.

    I was hoping that the offline installer would allow me to pre-stage since i have a few polling engines that have high latency due to their location.

  • Ok. New information.  I WAS able to use the Pre-stage feature with the offline installer to upgrade from 2020.2.5 to 2020.2.6 HF4 (Orion) and HF3 for my modules - npm, wpm and udt.

    High level.

    Use the offline installer to pre-stage the main polling engine. Then you go to the My Orion Deployment on the web to perform the rest of the polling engines by selecting the Pre-Stage button. The gui looks confusing because it uses the same gui that you use to perform the ugprades - just ignore the upgrade labels and continue through. Eventually you will get to the list of your polling engines. I wouldn't recommend excluding any polling engines (if you are thinking of testing one and then coming back). It's really designed to splash the install files across all your polling engines in one shot. If you do only select one or 2 and exclude others you will need to cancel the pre-stage and start over - no big deal but you will have to re-do the pre-stage to the same servers you had done as well as those you excluded. Again not a biggie but sharing.

    I did run into an issue in which 2 files were missing for the pre-stage. No idea how these files ended up missing as i used the same offline iso in dev and did not hit this issue. Any way, the files that were missing for my pre-stage (and were a blocker as i could not continue without having them) were

    VIM Hotfix 3.msp
    VMAN Hotfix 3.msp

    Luckily, I found those in my dev environment and copied them over to my main polling engine and then the pre-stage worked fine.  Once you are done with your pre-stage, the Upgrade button will become available and you can use that button once your change window starts.  Good Luck!

  • Hi,

    This post is the only result on the entire internet if I search for: solarwinds "VIM Hotfix 3.msp"
    So here I am.

    I just ran into the same issue with missing files. I have two environments and got the same error for both of them. Missing both of those files when trying to upgrade to the latest hotfix update while in offline environments via the web gui, after pre-staging first.

    The upgrade I'm trying to do, is this:
    Orion Platform: HF2 -> HF5
    NCM: HF1 -> HF2
    NPM: HF2 -> HF3
    NTA: NF1 -> HF2 (NTA only in one of the environments).

    "VIM Hotfix 3.msp" and "VMAN Hotfix 3.msp" does not exist on any of the servers, nor inside of Solarwinds-Orion-HotFix-2020.2.6-OfflineInstaller.exe.
    Not sure why it's trying to find hotfix3-files for VIM and VMAN anyway, when hotfix5 is out for both, also with not the correct file names from what I can see from the hotfix5 installes. They should contain version numbers too?
    The correct files inside ProgramData\SolarWinds\Installers\ should probably be "VIM-2020.2.6.50176-VIM Hotfix 5.msp" and VIM-2020.2.6.50176-VMAN Hotfix 5.msp.

    Did you ever figure out why they were missing, or does anyone else know anything about how to fix this?


    /Morten