Solarwinds trap Service failing to start after an update to NPM 10.2

Hi guys and girls:

i've just finished the update to the latest 10.2 NPM version. it's very nice but i'm having problems trying to start the trap service. the SNMP service is stopped as i was instructed, but the Solarwinds Trap service still doesn't want to play nice. any help?

  • Hi Jjimenez--

    Please take a look at the document Sean Martinez posted at the bottom of this thread.  Let me know if this helps.

    Thanks,
    DH

  • This is the error:

     

    Event Type:    Error
    Event Source:    SolarWindsTrapService
    Event Category:    None
    Event ID:    1004
    Date:        11/22/2011
    Time:        3:15:07 PM
    User:        N/A
    Computer:    ORION
    Description:
    Service Start Failure. Unable to register with SNMP Trap Service for SNMP Trap reception. Try to following to correct the problem:

    1. Click Start > Control Panel > Add or Remove Programs.
    2. Click Add/Remove Windows Components.
    3. Click Management and Monitoring Tools, confirm it is checked, and then click Details.
    4. Confirm that Simple Network Management Protocol is checked, and then click OK.
    5. If Simple Network Management Protocol was not checked, complete the Windows Components installation wizard.
    6. Click Start > Control Panel > Administrative Tools > Services
    7. Confirm that the SNMP Trap Service is Disabled.
    8. If the SNMP Trap Service is not Disabled, right-click SNMP Trap Service, and then click Stop.

    For more information, see Help and Support Center at go.microsoft.com/.../events.asp.

  • Thanks for the info, but it's not the answer. It's about configuring SNMP v3 on Cisco equipment. My trouble is starting a windows service (Server 2003). but thanks anyway

  • 289129

     

    that's the support ticket number

  • FormerMember
    0 FormerMember over 9 years ago in reply to jjimenez

    HI,

    Just for information :-)

    I have had the same issue while installing a test version of 10.2 on a 2003R2 server .  I have tried to repair the services without success. As my server was not up to date with windows updates (.net for examples) I have applied these updates and re-install 10.2 . It finally works so I suspect any windows updates to help.Unfortunately as the list of WU was quite long (around 30) I cannot tell you more.

     

    vincent.

  • The server is up to date (11/23/2011), but i want to know if there's any requirement regarding OS patches, .NET versions, etc. anyone?

  • Hi Jose,

    I took a quick look at you case. In the output of "netstat -ano" I see 

     UDP    0.0.0.0:162            *:*                                    2124

    which means there is "something" already listening on the port 162 which is receiving SNMP traps.

    Make sure that Windows SNMP Trap Service is really stopped and disabled (as mentioned as point 7.).

    If you run "netstat -anob" you can see name of the process that opened the port 162, like this:

     UDP    0.0.0.0:162            *:*                                    3700

    [snmptrap.exe]

     

    Thanks

    Jan

  • There's some "EventReceiver.exe" listening on the port 162. And is logged as "local service" as the user. i did send to Hati the output.

  • sorry. the service "SNMP Trap service" is logged as i told you. it appears "stopped". "SNMP Service" is running.

  • the issue was solved. there was an app using the UDP port. we'll move the executable, so it'll use another port. thanks for the help also Hati's help. Thanks a lot