Upgrade IPM Orion Platform 2018.2 to 2020.2.1 HF2

I mounted the iso 2020.2.1 HF2 offline installer "Solarwinds-Orion-IPAM-2020.2.1-OfflineInstaller.iso" on my server and run the  and receive an error message. 

"D:\contents.psd1" System.securty.Securityexception: "D:\content.psd1":Authenticode Verification Unknownerror ({ "SignerCertificate": {  "Archived": false, 

I've checked the certs on the server nothing has expired ? Anyone seen this before. 

  • I am facing a similar issue when trying to install Orion NPM 2020.2.1 HF2 on Windows Server 2019. I am starting from a clean installation though

  • I have the same error.  When i look at the digital signature of the content.psd1 file, i I saw it had no timestamp so i clicked on the details.  Opening the details showed that the certificate was explicitly revoked by its issuer.  Which means that SolarWinds purposefully revoked the signer that was used on the content.psd1 file after signing it and including it in the build we downloaded.  I am going to try downloading a new package and see if I get the same result.

  • So i just went to download, and it looks like they already have a 2020.2.4 installation. Not sure why the revoke on the other one, but maybe someone from SolarWinds can comment.  The 2020.2.4 installer is running fine.

  • Had exact same issue but with the NPM offline installer (I believe the offline installer is all products anyway - so the fact that you selected "IPAM" just means you get the same package anyway.)

    In trying to determine what the issue is, found this thread. As we did not find anything from our end obviously blocking verification etc. of the cert in question, decided to open a support case.

    Support response - instructions to turn off Signature/Certificate verification on the SolarWinds server.

    I have responded to say that this is not going to happen.

    Will update with any resolution that actually makes sense and doesn't involve turning off the exact mechanisms that were involved in the originating issues.

  • I ended up not using the installer that had its certificate revoked.  I just downloaded the latest available installer and that newer installer was able to perform the uninstall and re-install the product.

  • I had the same issue upgrading to 2020.2.4 using the offline installer, after reading some logs and reviewing the certificates I found the CRL issue and this is how I fixed it:

    -Mount the offline installer on a computer with internet access

    -Go to properties for the content.psd1 file, then to the Digital Signatures Tab, there is only one certificate for Solarwinds Worldwide LLC, select it and click details in the same section

    -In the Digital Signature Details window click View Certificate

    -In the certificate window that just opened go to Details Tab and select Copy to file

    -The Certificate Export Wizard will open, follow the steps and the format you want to use is DER, once you have exported it go to the Certification Path

    -In the certification path section you will find there are two other certificates, DigiCert SHA2 Assured ID Code Signing CA and DigiCert, you will export them as well, same process as the previous certificate

    -Now, those three certificates that were exported have to be installed in the machine where you want to install Solarwinds using the offline installer

    These are the stores where I installed them:

    Solarwinds Worldwirde, LLC cert -----> Trusted Publishers

    DigiCert SHA2 Assured ID ----->  Intermediate Certification Authorities

    DigiCert -----> Trusted Root Certification Authorities 

    After those steps the offline installer finally loaded.

  • I followed the steps provided by and the installer offline its working. Thanks!