20 Replies Latest reply: Jan 12, 2014 3:12 PM by anthonywdatacom RSS

EMC Clariion AX4-5

its314ter

Does SAN Monitor work with the EMC Clariion AX4-5 f

THNX

 
  • Re: EMC Clariion AX4-5
    michalB

    We believe it should be working.

    As per EMC: "In general, commands supported by CX4 series, CX3 series, and CX series systems are supported by AX4-5 series and AX series systems. Because of some functionality differences, there are some commands that are unique to AX4-5 series and AX series systems and others that are not available."

    • Re: EMC Clariion AX4-5
      turbotalon

      We've got a Clarion AX-4 unit.   When trying to run the SAN Monitor utility I get the following error...

      usage: getlun

      Invalid command line parameters: -slst

       

      We have the latest version of the EMC Navisphere CLI tools installed.

       

      Any advice on how I can resolve this issue?

      Thanks,

      Shawn

      • Re: EMC Clariion AX4-5
        SteveSW

        turbotalon,

        Shutdown your application and edit the config file (ClarionCliMonitor.exe.config). Change the LoggingLevel value to Debug. Run the application again and collect the log files after it has run a while. The logs can be found at:

        <AllUsersProfile>\Application Data\SolarWinds\ClariionCliMonitor\ClariionCliMonitor.log.

        Once you have that information contact me again on this forum and we'll arrange a way for you to send us the log information.

        --

        Steve

        • Re: EMC Clariion AX4-5
          ahahum

          SteveSW - I have the same problem and have enabled the debug logging.  Hopefully you can assist.

           

          How would you like me to get you the log file?

          • Re: EMC Clariion AX4-5
            SteveSW

            ahahum,

            You should be able to private mail the logs to me through the forum.

            --

            Steve

            • Re: EMC Clariion AX4-5
              ahahum

              Nope, I get this message:

              This feature requires a participation level that you have not achieved. Please feel free to post your question on the Forums and we will get to it ASAP.

               

              Please get the file from here:

              http://dl.dropbox.com/u/2099598/ClariionCliMonitor.log

               

              If you will let me know after you've gotten it, I will remove this from the public access.

               

              Thank you.

              • Re: EMC Clariion AX4-5
                SteveSW

                ahahum,

                I got your logs. We will look at them and let you know what we find out. Give us a couple of days to look into it.

                --

                Steve

                • Re: EMC Clariion AX4-5
                  ahahum

                  Excellent, thank you, Steve.


                  I look forward to hearing back from you.  Please let me know if you need any more information from me.

                  • Re: EMC Clariion AX4-5
                    michalB

                    ahahum, we went through the logs and they show the command parameters accepted by your NaviSecCLI application differ a lot from what SAN Monitor supports. Even if we updated the application to work well with your device, we would not be able to collect the performance information. Are you sure you have the latest version of NaviSecCLI installed?

                    • Re: EMC Clariion AX4-5
                      ahahum

                      I show Navisphere CLI version 7.30.11.0.55.  Power link shows this version was from Sept. 23, 2011.

                      • Re: EMC Clariion AX4-5
                        ahahum

                        FYI, I have tried installing this software on a different machine and I get the same results with this version of Navi CLI.

                         

                        Any ideas?

                        • Re: EMC Clariion AX4-5
                          michalB

                          I am sorry for the late response. I have checked with our Storage Manager team and learned the AX series do not provide performance data the way we read them.

                          • Re: EMC Clariion AX4-5
                            ahahum

                            Thank you for the update - I'm using a Clariion CX300.  Does that make any difference?  I only posted in this thread because it was the same error.

                            • Re: EMC Clariion AX4-5
                              michalB

                              Alright, let me check back with the developers. We'll try to create some batch file to save the text outputs your NaviSecCLI provides so we can see the differences from what we actually support. I'll send you a private message when this is ready.

                              • Re: EMC Clariion AX4-5
                                michalB

                                ahahum,

                                I have sent you e-mail with details on troubleshooting.

                                • Re: EMC Clariion AX4-5
                                  madrianr

                                  we have also a AX4.5i and get the error: Invalid commandline paramters: -slst

                                  02/02/2012 21:44:23 [06] ERROR Polling Exception during polling: usage: getlun <lun-number> <-aa> <-at> <-bind> <-bp> <-bread> <-brw>
                                                <-busy> <-bwrite> <-capacity> <-crus> <-default> <-disk>
                                                <-drivetype> <-dsa> <-element> <-ena> <-ff> <-hrdscsi>
                                                <-idle> <-idt> <-it> <-mp> <-name> <-nminus> <-owner>
                                                <-parityelements> <-pd> <-pic> <-prb> <-prefetch> <-prf>
                                                <-ps> <-psm> <-qavg> <-qmax> <-que> <-rb> <-rc> <-rd3>
                                                <-rchm> <-reads> <-remap> <-ret> <-rh> <-rhist> <-rr> <-rwf>
                                                <-rwr> <-service> <-sftscsi> <-srcp> <-ss> <-ssm>
                                                <-stripe> <-totque> <-type> <-upb> <-verify> <-was>
                                                <-wc> <-wch> <-uid> <-wh> <-whist> <-wr> <-writes>
                                                <-rg> <-state> <-private> <-usage> <-sc> <-snapshot>
                                                <-offset> <-addroffset> <-ismetalun> <-idleticks> <-busyticks>
                                                <-lunidleticks> <-luncache> <-lunbusyticks> <-trespass> <-status>

                                  Invalid command line parameters: -slst


                                  please help...

                                  • Re: EMC Clariion AX4-5
                                    michalB

                                    madrianr, do you have Statistics Logging enabled in Navisphere web interface?

                                    • Re: EMC Clariion AX4-5
                                      madrianr

                                      Yes - Logging is aktivated!

                                      • Re: EMC Clariion AX4-5
                                        michalB

                                        I will contact you via private message.

                                        • Re: EMC Clariion AX4-5
                                          anthonywdatacom

                                          I have just installed the Naviseccli and SAN Monitor for EMC.

                                          I have the same error message as Madrianr, and note from another post that the AX4 SANs may not be supported with SAN Monitor.

                                          Can you confirm that this may be the case or advise on the best method to install

                                          When installing Naviseccli, I did not select certificate or setup the username and password

                                          When installing SAN Monitor, followed the prompts and completed a standard install.

                                          SAN Monitor and Naviseccli are on the same server, this server is not connected to the storage via Fibre, but the IP addresses of the SAN controllers are contactable by all devices.

                                          Any help, greatly appreciated.

                                          Cheers