0 Replies Latest reply on Nov 3, 2015 11:08 AM by bmcmcm

    Alert Central Mailbox Setup

    bmcmcm

      I was trying out Alert Central for the first time, but I found that the initial setup is troublesome for Exchange. I went to the trouble of getting a mailbox and a user account requested and setup, then found that Alert Central can't login via EWS, POP, or IMAP. I've tried using username formats like domain\username, username @domain, and just username. No formatting version works, they all give me an authentication failure. I can manually logon to the mailbox in with Outlook Webmail, but I do have to specify the mailbox in the URL. It is a shared mailbox, the user account does not default to the mailbox. From various Technet and other posts, it appears that you should be able to specify the mailbox via the account name being set to a format like domain\username\mailboxname or user@domain\mailboxname. I tried many combinations of that as well, and was never able to get the application to logon. The Alert Central administrator guide glosses over the email setup like it is a simple matter, but it's proven to be quite troublesome. the administrator guide doesn't say anything about the specifications for the mailbox, like it must not be a shared mailbox or anything like that, so the assumption is a that any mailbox will work. I've got a valid account and a valid mailbox, but I can't find a way to get the application to successfully logon and use it.

       

      Anyway, I know for sure that the user account and mailbox work properly, but I'm not sure if Alert Central is capable of using a mailbox that has to be specified.

      Here are the kind of errors I'm getting, although I've tried many formats for the account name (with and without a mailbox name):

       

      DEBUG: setDebug: JavaMail version 1.4.5

      DEBUG: getProvider() returning javax.mail.Provider[STORE,ews,com.solarwinds.mail.ews.EWSStore,SolarWinds,1.0]

      could not auto-discover URL (null)

      problem with URL: http://outlook.mailhost.com

       

      DEBUG: setDebug: JavaMail version 1.4.5

      DEBUG: getProvider() returning javax.mail.Provider[STORE,pop3,com.sun.mail.pop3.POP3Store,Sun Microsystems, Inc]

      DEBUG POP3: mail.pop3.rsetbeforequit: false

      DEBUG POP3: mail.pop3.disabletop: true

      DEBUG POP3: mail.pop3.forgettopheaders: false

      DEBUG POP3: mail.pop3.cachewriteto: false

      DEBUG POP3: mail.pop3.filecache.enable: false

      DEBUG POP3: mail.pop3.keepmessagecontent: false

      DEBUG POP3: mail.pop3.starttls.enable: false

      DEBUG POP3: mail.pop3.starttls.required: false

      DEBUG POP3: mail.pop3.apop.enable: false

      DEBUG POP3: mail.pop3.disablecapa: false

      DEBUG POP3: connecting to host "outlook.mailhost.com", port 110, isSSL false

      S: +OK The Microsoft Exchange POP3 service is ready.

      C: CAPA

      S: +OK

      TOP

      UIDL

      SASL NTLM GSSAPI PLAIN

      USER

      STLS

      .

      DEBUG POP3: authentication command trace suppressed

      DEBUG POP3: authentication command failed

      C: QUIT

      S: +OK Microsoft Exchange Server 2010 POP3 server signing off.

       

      EBUG: setDebug: JavaMail version 1.4.5

      DEBUG: getProvider() returning javax.mail.Provider[STORE,imap,com.sun.mail.imap.IMAPStore,Sun Microsystems, Inc]

      DEBUG: mail.imap.partialfetch: false

      DEBUG: mail.imap.statuscachetimeout: 1000

      DEBUG: mail.imap.appendbuffersize: -1

      DEBUG: mail.imap.minidletime: 10

      DEBUG: trying to connect to host "outlook.mailhost.com", port 143, isSSL false

      * OK The Microsoft Exchange IMAP4 service is ready.

      A0 CAPABILITY

      * CAPABILITY IMAP4 IMAP4rev1 AUTH=NTLM AUTH=GSSAPI AUTH=PLAIN STARTTLS UIDPLUS CHILDREN IDLE NAMESPACE LITERAL+

      A0 OK CAPABILITY completed.

      DEBUG IMAP: AUTH: NTLM

      DEBUG IMAP: AUTH: GSSAPI

      DEBUG IMAP: AUTH: PLAIN

      DEBUG: protocolConnect login, host=outlook.mailhost.com, user=user@domain\mailboxnam@domain, password=<non-null>

      DEBUG IMAP: AUTHENTICATE PLAIN command trace suppressed

      DEBUG IMAP: AUTHENTICATE PLAIN command result: A1 NO AUTHENTICATE failed.