2 Replies Latest reply on Oct 1, 2015 11:47 PM by jtallerico

    LanSweeper Integration

    jtallerico

      I recently purchased LanSweeper to integrate with WHD. In my initial testing, I am getting too many assets like monitors etc. that I really don't want to see in WHD. I'm also getting duplicate assets. The LS url fails in WHD. Is there any way to filter what comes over from LS? I still can't figure out why I'm getting so many duplicates.

        • Re: LanSweeper Integration
          kellytice

          For duplicates I'd likely open a support ticket.   It should be able to recognize that a machine is the same through a combination of serial number/mac address/machine name/ip address.   If that's not happening it may be a bug or environmental issue. It may be that it *needs* a unique serial number and if that is not in the lansweeper db perhaps that is an issue (though i don't know 100% if that is field is required to be present).

           

          I don't believe there is a way to filter what kind of assets are pulled in from the default LanSweeper connection.   If you are using a full or Express version of SQL for LanSweeper, you might be able to create a filtered View in the SQL that LanSweeper uses, and then use the "Database Table or View" Discovery Connection type instead of the "LanSweeper" Discovery Connection type in Web Help Desk so that you're only pulling in assets from that custom view.  

            • Re: LanSweeper Integration
              jtallerico

              Kelly, I was able to remove the duplicates by removing the existing inventory and resyncing LanSweeper. I changed the asset ID to allow for updates which seemed to resolve the problem. Still trying to eliminate the inventory items that I don't want to see in Web Help Desk. We name computers by a tag number which is "TAGXXXXX" . I can filter the search to just show these tag numbers which may work for my needs. I removed the monitor search from LanSweeper which helped quite a bit.