25 Replies Latest reply on Oct 11, 2016 4:34 PM by equalswql

    Error with Discovery Processing Results NPM 11.5.2

    bharris

      We are receiving an error when trying to use the network sonar discovery. "An error while processing results has occurred. See discovery log for more details."

      Discovery Error.PNG

      Also tried to add the nodes by clicking the "results" tab and get the following error.

      "ProvideFault failed, check fault information."


      Discovery Error 2.PNG

        • Re: Error with Discovery Processing Results NPM 11.5.2
          bharris

          We found the issue with this.  Found that our error matched up closely with this KB article, but not exactly

          http://knowledgebase.solarwinds.com/kb/questions/6063/Unable+to+List+Resources+from+Nodes+Assigned+on+the+Additional+Polling+Engine

           

          We looked at the BusinessLayerHost Log and in the block where it was loading various plugins it was showing that the discovery plugin could not be found:

          2015-07-14 13:26:19,153 [8] ERROR SolarWinds.BusinessLayerHost.PluginInstanceAppDomain - Plugin "Core Business Layer" failed to start.

          System.IO.FileNotFoundException: Could not load file or assembly 'SolarWinds.Orion.Core.Discovery, Version=2015.1.25300.8197, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

          File name: 'SolarWinds.Orion.Core.Discovery, Version=2015.1.25300.8197, Culture=neutral, PublicKeyToken=null'

           

          Did not see the discovery plugin file in the %installedpath%\Solarwinds\Orion folder.  We found SolarWinds.Orion.Core.DiscoveryPlugin.dll in %installedpath%\Solarwinds\Orion\Discovery\SolarWinds.Orion.Core.DiscoveryPlugin.dll and copied it to %installedpath%\Solarwinds\Orion\.

           

          We stopped all services after copying and restarted them. It has resolved the error.

           

          Hope this helps out anyone that may be having the same issue.

          • Re: Error with Discovery Processing Results NPM 11.5.2
            bharris

            Well, I just started getting the error again and the DLL file is still there.  Not sure what the heck is the cause...

             

            2015-07-29 12:33:16,917 [8] INFO  SolarWinds.BusinessLayerHost.PluginInstanceAppDomain - Starting plugin: "Core Business Layer"

            2015-07-29 12:33:16,979 [8] ERROR SolarWinds.BusinessLayerHost.PluginInstanceAppDomain - Plugin "Core Business Layer" failed to start.

            System.IO.FileNotFoundException: Could not load file or assembly 'SolarWinds.Orion.Core.Discovery, Version=2015.1.25300.8197, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

            File name: 'SolarWinds.Orion.Core.Discovery, Version=2015.1.25300.8197, Culture=neutral, PublicKeyToken=null'

             

             

            Server stack trace:

               at SolarWinds.Orion.Core.BusinessLayer.CoreBusinessLayerPlugin.Start()

               at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)

               at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

             

             

            Exception rethrown at [0]:

               at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

               at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

               at SolarWinds.BusinessLayerHost.Contract.BusinessLayerPlugin.Start()

               at SolarWinds.BusinessLayerHost.PluginInstanceAppDomain.Start()

            • Re: Error with Discovery Processing Results NPM 11.5.2
              mikegale

              I started getting this same message a couple days ago too. One day I was importing elements just fine and the next I was getting this message. We did not install any patches or hotfixes or make any other changes. What fixed it for us was simply restarting all services on the core engine using the "Orion Service Manager" and I've since imported hundreds of systems.

              • Re: Error with Discovery Processing Results NPM 11.5.2
                lawyer26

                We followed the steps above to copy the dll.  It worked for a while then the issue came back.  We then applied OrionPlatform-v2015.1.2-HotFix3 and the issue went away but came back again.  We are now planning on installing the latest service pack (OrionPlatform-v2015.1.2-HotFix4).  However reviewing the notes for Hotfix4 indicates that this was supposed to be fixed in Hotfix2 (included in Hotfix3 and Hotfix4 as well) so we shouldn't be having the issue again.  It is possible that running the through the installation of the hotfix just masks the issue and it will come back again.  We are seeing this occurring on two separate systems both running NPM 11.5.2 with other modules that differ between systems.  If anyone has any additional input, it would be nice to get this fixed permanently as it causes work slowdowns while we either wait until there is a fix or add devices manually.  We have opened up multiple cases as well and we get the same response (Please apply the hotfix, that'll fix it and everything else that you are having problems with.  Oh, you can't install that now because your systems are in production and you can't take an outage?  Well, I'm sure that everything will get fixed by THIS hotfix.  We really mean it THIS TIME.)

                • Re: Error with Discovery Processing Results NPM 11.5.2
                  sacosgrove

                  If this issue pops up again perform the following:

                   

                  1.)  Open the Orion Service Manager and shutdown everything.

                  2.)  Delete all files from the C:\windows\temp directory.

                  3.)  Start everything in Orion Service Manager

                    • Re: Error with Discovery Processing Results NPM 11.5.2
                      bharris

                      Do you know the reason why deleting the files from temp is fixing the issue?  I looked at the temp folder and other than temporary report PDFs, I'm not seeing anything else related to Solarwinds.

                        • Re: Error with Discovery Processing Results NPM 11.5.2
                          sacosgrove

                          Just to clarify, clear out the windows/temp directory on your primary poller.  I've found this workaround is still effective when I get a discovery error.  Here is the email message from William Muhle of SolarWinds:

                           

                          The issue you are having is a known issue that is caused by the use of the OLE DB file that we use with the discovery.  It is something that is being worked on by development (and hotfix 2 was supposed to have helped with it).  The temporary fix that we applied was to stop the services, clean out the C:\Windows\Temp directory, then restart the services.  Once we did this, you were able to complete the discovery without any issues.

                           

                          Part of Hotfix 2 is designed to make it so that you do not have to do that cleanup as often.  Aside from that, development is working on the permanent fix for this issue, so keep your eyes on further releases and it should be fixed sooner than later.

                           

                          Let me know if you have any other questions sir and I’ll be happy to reopen the case if you do.

                           

                          Thank you and have a pleasant day,

                          William Muhle,

                          Solarwinds Intermediate Application Engineer

                           

                           

                      • Re: Error with Discovery Processing Results NPM 11.5.2
                        sacosgrove

                        It's come back for me as well (and it will, it's expected as this point). I just have to perform the workaround again and I'm able to import my discovery results.

                        • Re: Error with Discovery Processing Results NPM 11.5.2
                          lawyer26

                          There isn't a permanent fix for this.

                          • Re: Error with Discovery Processing Results NPM 11.5.2
                            jedi755

                            Having the same issue even with Hotfix 6.  I was able to get working after clearing C:\Windows\Temp as well.  Hopefully this gets fixed soon.

                            • Re: Error with Discovery Processing Results NPM 11.5.2
                              jon.rickert@scientificgames.com

                              I have the latest hot fixes applied and I'm still seeing this at least every week or two.  I just opened "Case # 903063 - Error while processing results from network sonar discovery, see discovery log for more details" so I see what they have to say today.  I'll get back to you folks.

                              • Re: Error with Discovery Processing Results NPM 11.5.2
                                jon.rickert@scientificgames.com

                                Just wanted to share...

                                 

                                According to support it's in their bug tracking system, still in development, and a fix shouldn't be expected in the near future.  BTW, I installed hot fix 6 and it does not help this either and according to the release notes I didn't expect it to.  Just wanted to clear that up in case anyone it wondering.  I guess we will continue to clear c:\windows\temp\ for awhile until they release a fix.

                                 

                                 

                                Case # 903063 - Error while processing results from network sonar discovery, see discovery log for more details.

                                 

                                 

                                02 Dec 2015 06:28:00

                                 

                                Author: Customer Support
                                Recipient: SW21763489 WMS : Jon Rickert

                                Hi Jon,I found your issue in our bug tracking system. Unfortunately it is still in development phase so a fix won't be released in the near future. This issue is reproducible for us on our demo site. I hope that helps at least a little bit.Thanks for your patience,Shawnda

                                 

                                 

                                01 Dec 2015 12:13:00

                                 

                                Author: Customer Support
                                Recipient: SW21763489 WMS : Jon Rickert

                                Hi Jon,I haven't forgotten about you. Truthfully, I had to open a helpdesk ticket for my login to the bug tracking which is brand new (I had been using the prior version). Since I need up to date info I need to get the login for the new one.I will get back to you on this one. Thanks,Shawnda

                                 

                                 

                                26 Nov 2015 05:51:00

                                 

                                Author: Customer Support
                                Recipient: SW21763489 WMS : Jon Rickert

                                Hi Jon, Thank you for contacting SolarWinds Technical Support. My name is Shawnda and I will be working on this case with you. Unfortunately if you attached a log to this case, it did not come through. What version of NPM/SAM are you at? Did you install any hotfixes? Can you reattach the log you sent it? FYI, I will be out until Monday Nov 30th. Happy Thanksgiving, Shawnda Recksiedler Solarwinds Technical Support If you have any feedback about your support case and the way it has been handled, we invite you to send your comments to TechnicalSupportFeedback@solarwinds.com Please note that I am in the Boulder CO office and my working hours are from 7:30am - 4:00pm MDT We are a 24x7 operation and if your case needs immediate attention outside of my work hours please call the support helpline quoting your case number and one of our other offices will be able to assist you. http://www.solarwinds.com/company/contact.aspx

                                 


                                Load whole message

                                 

                                24 Nov 2015 04:10:00

                                 

                                Author: SW21763489 WMS : Jon Rickert
                                Recipient: Customer Support

                                Error while processing results from network sonar discovery, see discovery log for more details.

                                 

                                • Re: Error with Discovery Processing Results NPM 11.5.2
                                  equalswql

                                  Although I'm on 11.5.3 and don't have the exact same error in logs - I had a similar issue. Discovery hanging/canceling with errors and upon rediscovery the previous results would append - if I started with 4 nodes it would append 4 more and find 8.

                                   

                                  The final solution to this was to run a repair for the NPM package on the additional poller which I was assigning the discovery to. Immediately after doing the repair and completing the associated config wiz - discoveries were again working.