0 Replies Latest reply on Jul 4, 2015 4:55 PM by samundson07

    Custom view user permission issue

    samundson07

      So I ran into a problem the other day that just doesn't make any sense to me. When we are on the page of any single node that we have monitored we have created custom views depending on the device type. There is one view that all devices have regardless of the device type. We have a view that show the last 10 audit events for the node which proves to be very useful if something pops into alarm because you can see right away whether it had been unmanaged and became remanaged or if it is legitimate. So before our upgrade to 11.5 I had cleaned up all the local users permissions and secured everything as much as I could. At this time my group had all permissions except for report management and admin rights and they were able to see this view just fine. Recently we hired a new person onto our group and he brought up the issue with me that he wasn't able to see that window when it should be there. I tried a couple things which didn't work and just for the heck of it I tried giving him admin rights to see if it would change anything and right away he was able to see it. So next time I saw the other members of my group I checked with them and they were having the same issues.

       

      Needless to say I had to give everyone admin rights just to see this one view which to most people would be a big no no. Is it just me or does this seem a little odd? According to my understanding all admin rights really gives you permissions to do is to add, delete, or modify user accounts. Has anyone had or noticed an issue like this as well? Does anyone have any suggestions or ideas that I may be missing? Any information would be greatly appreciated!