1 Reply Latest reply on Jun 9, 2015 9:01 AM by jtryon81

    CatTools scheduled jobs not running correctly


      I am new to CatTools and recently moved a customer's CatTools program from one server to another.  The new server OS is Windows Server 2008 R2, and version of CatTools is 3.3.11.


      The issue I am experiencing after importing their previously-set jobs, email notifications and reports is that the jobs just randomly won't run.  If I am logged into the server and have CatTools running, everything works fine.  When I have the program closed and in Timer Mode, but still logged on to the server, it seems to still run the jobs ok *most* of the time.   However, it is hit or miss when I log off the server--sometimes the jobs run and other times they do nothing.


      I have CatTools installed as a service, with a local admin account running the Kiwi CatTools service.  The service seems to run without issue.  The two clues I'm seeing that I don't know what to do about are that the mail queue seems to be getting set to "off" randomly, when I check the SendMailLog.  Sometimes it gets set to On when I close the program, and sometimes it gets set to Off.  Does the mail queue just turn on after a scheduled job runs that has the email notification configured?  The other clue is that in the InfoLog, sometimes I see "Unable to start timer, database is not connected" messages.  Again, no rhyme or reason as to why this happens, but nothing runs after I see those messages.


      Can anyone assist with this?  Is there a compatibility issue with Server 2008?  I have put a ton of time into this and every time I think it is fixed, the customer comes back and says that they're not getting their email notifications again.  TIA.

        • Re: CatTools scheduled jobs not running correctly

          Another thing that I have been wondering: the Device.Backup.Running Config activity when run on a Nexus 3k-7k returns the time at the top of the running config, where a "regular" Cisco switch doesn't.  As a result, CatTools reports that there are changes made to the configuration of those devices when there are no changes.  Is there any way to modify the activity so that it ignores the time field on Nexus equipment?