0 Replies Latest reply on Jun 9, 2015 2:51 AM by lyubo@doitwise.com

    NPM installation issue

    lyubo@doitwise.com

      Hey,

       

      I am trying to install SolarWinds NPM and it is failing.

      First I tried with the latest version 11.5 and when the configuration wizard started I got an error that it can't connect to the database.

      Then I recreated the machine and tried with version 11.0.1 and got the same issue - the installation went fine until the configuration wizard started and it showed an error that can't connect to database.

      I am using the standard method of install with SolarWinds automatically installing the MS SQL instance on the local host and IIS. The host is running Windows Server 2008 R2 Datacenter which is a fresh installation - nothing else running on it.

      After this I tried to rerun the installation of NPM and it completed for 2-3 minutes not doing anything - seems like the actual NPM installation is done fine. Next thing is I see the configuration wizard starting and failing with the same error. Then I can manually start the Configuration wizard and it asks me for SQL Server and the credentials. So I choose the local Orion instance and hit the button "Use original database login and password" and click on Next - I see the error:

      "Can not connect to the SQL Server. The original error is: Login failed for user 'SolarWindsOrionDatabaseUser'"

       

      I try to start the Orion Database Manager and try to "Add default server" and still get the error:

      "A network-related or instance-specific error occurred while establishing a

      connection to SQL Server. The server was not found or was not accessible.

      Verify that the instance name is correct and that SQL Server is configured to

      allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"

       

      As I already tried recreating the OS and installing different versions of NPM which has worked on a different host, I think the issue is with the local SQL which NPM is trying to create.

      So is there a way that I can recreate the database? How can I do that?

       

      The difference between the working and non working envs is that the non working one is in the Microsoft Azure Cloud..

       

      Lyubo