5 Replies Latest reply on Jan 28, 2015 5:12 PM by steve_dtran

    FTP Voyager command does not work?

    steve_dtran

      I'm running this script on my PC1 with FTP Voyager version 16.2 but it does just open FTP voyager and DOES NOTHING.  No file transfer at all.

      I checked and I do see 2 zip files inside d:\temp\ folder.  However if I take this same script and execute on another PC and it work fine.  This PC has same FTP voyager version and same configuration as PC1.

       

      Can someone help? thanks.

       

      FOR %%G in (d:\temp\*.zip) do (

      echo.found %%G

      "C:\Program Files\RhinoSoft\FTP Voyager\FTP Voyager.exe" profile="Art_Test_FTPserver" put=%%G remote="/" logfile=NAR_upload.log -nostartupwizard -nosplash autoquit=1

      Echo uploaded %%G successfully

      Echo.

      )

      Echo.

      Echo completed ...

        • Re: FTP Voyager command does not work?
          josh.d

          Are there spaces in the file names on pc1?  Does the user running the script have full permissions to list & read the files?

           

          Are the files or directories different between the 2 computers?

           

          Is there any errors or interesting entries in the log?

            • Re: FTP Voyager command does not work?
              steve_dtran

              Hi, thanks for quick respond.

               

              I double checked and both servers are having same folder, file name and location, and the file name does not contain "spaces".  I'm running the exact script below with local admin on both PCs and still does not work.

               

              I can't not even issue a simple command line to put a file from PC2.  It open up the FTP Voyager and just sitting there, instead of display the file transferred.

               

              EX: "C:\Program Files\RhinoSoft\FTP Voyager\FTP Voyager.exe" profile="Art_Test_FTPserver" put=C:\temp\nar.log remote=d:\temp

               

              and it still won't execute correctly.

               

              However, if I take the same command line and run on PC1 and it works fine.

               

              Can you help? thanks.

              • Re: FTP Voyager command does not work?
                steve_dtran

                Hi Josh,

                 

                Here is the log from FTP Voyager GUI screen after I execute the command below:

                 

                C:\Users\Configadm>"C:\Program Files\RhinoSoft\FTP Voyager\FTP Voyager.exe" profile="Art_Test_FTPserver" put=c:\temp\narFromATT_SFTP.log remote=/

                 

                 

                STATUS>     Querying server for supported authentication methods

                COMMAND>     SSH_MSG_USERAUTH_REQUEST: user: SFAgencyTP; service: ssh-connection; type: none

                     SSH_MSG_USERAUTH_FAILURE: partial: 0; available authentications: publickey, password

                STATUS>     Supported authentication methods: publickey, password

                COMMAND>     SSH_MSG_USERAUTH_REQUEST: user: SFAgencyTP; service: ssh-connection; type: password

                     SSH_MSG_USERAUTH_SUCCESS: authentication successful

                STATUS>     Login successful.

                COMMAND>     SSH_MSG_CHANNEL_OPEN: type: session; local channel: 0

                     SSH_MSG_CHANNEL_OPEN_CONFIRMATION: local channel: 0; remote channel: 0

                COMMAND>     SSH_MSG_CHANNEL_REQUEST: remote channel: 0; request type: subsystem; subsytem: sftp

                     SSH_MSG_CHANNEL_SUCCESS: channel request succeeded; local channel: 0

                COMMAND>     SSH_FXP_INIT: client version: 6

                     SSH_FXP_VERSION: server version: 3

                STATUS>     Negotiated SFTP version 3

                COMMAND>     SSH_FXP_REALPATH: translating path: .

                     SSH_FXP_NAME: translated path: /

                STATUS>     Listing contents of: /

                COMMAND>     SSH_FXP_OPENDIR: path: /

                     SSH_FXP_HANDLE: handle: 0x00000000

                     SSH_FXP_STATUS: status: SSH_FX_EOF; description: End of file

                COMMAND>     SSH_FXP_CLOSE: handle: 0x00000000

                     SSH_FXP_STATUS: status: SSH_FX_OK; description: Success

                STATUS>     Listing complete: /

                 

                 

                Note: it seems like it stuck at the last line "STATUS> listing complete: / ??????

                  • Re: FTP Voyager command does not work?
                    josh.d

                    It looks like it connects & auths okay.  I'd start looking at the difference between the 2 computers, like maybe UAC or network segment location.

                     

                    Are you logging in using the same user id in both scripts?

                     

                    Do both scripts run at the same time (maybe one is blocking the other?)?

                     

                    Can you manually do the upload through the GUI?

                     

                    Does the user have write permissions on it's home directory?

                      • Re: FTP Voyager command does not work?
                        steve_dtran

                        I found the fixed for this issue, The PROFILE "Art_Test_FTPserver" must be located inside the "All Sites" and it CAN NOT be in RhinoSoft folder.

                         

                        So, I just right click on the "ART_TEST_FTPServer" profile and move it to "All Site" and it works like a charm.  Thanks.

                         

                        C:\Users\Configadm>"C:\Program Files\RhinoSoft\FTP Voyager\FTP Voyager.exe" profile="Art_Test_FTPserver" put=c:\temp\narFromATT_SFTP.log remote=/