13 Replies Latest reply on Jan 22, 2015 8:01 AM by ms52390

    CPU Alert only fires once

    ms52390

      I am going crazy with this alert. I have the setup below configured and when I save the alert it will fire once after my 1 minute of check time. Then it does not fire ever again. What am I doing wrong?

       

      I have checked time of day settings, reset is set to reset when trigger conditions are no longer true, no reset actions have been setup. All I have it do is shoot me an email.

      Capture.PNG

        • Re: CPU Alert only fires once
          RichardLetts

          Given CPU load can never be negative; all possible valid values are >=0, so the first condition is always true.

            • Re: CPU Alert only fires once
              ms52390

              I just tossed 0 in there for a value, but i have been trying all integers up to 10. My CPU load averages around 20-30% so It should fire an alert constantly until I do something to stop it. I only can get the alert to fire if I edit it and then save changes.

                • Re: CPU Alert only fires once
                  janene16

                  If the alert escalation any is not checked, the alert will only trigger once (as it stays ACTIVE) until the condition has been reset.

                  If you want to constantly have this alert notify you, you may want to edit the Alert and then go to Trigger Actions > Select and Edit the Alert Action > Edit Selected Action.

                  Next, go to the Alert Escalation tab and tick "Execute this Action repeatedly while the Alert is Triggered" and then set the time

                  Click OK to Submit.

                   

                  Let me know if this helps.

                  • Re: CPU Alert only fires once
                    mharvey

                    Is it firing on all devices that meet the criteria, or just on one device?  janene16 has a good point regarding alert escalation if you are expecting it to constantly fire on a device while it is in that condition.  Otherwise, if you're saying it's firing on one device and none of the others that meet the same condition, then there may definitely be an issue.

                • Re: CPU Alert only fires once
                  ms52390

                  janene16 Thank you for that suggestion, I originally had tried that as well.

                   

                  mharvey I think something else is going on. I have several nodes that fit into that "device_type" custom component with the type name containing "core". It fires twice, one email each for two separate nodes (after the alert is saved). It should continue to fire every minute with the current config but for some reason it only fires that initial time. The alert checks every minute, trigger condition is set at 30 seconds, and the alert escalation is set to every minute.

                    • Re: CPU Alert only fires once
                      mharvey

                      I agree, something seems up.  Without alert escalation the alert will only fire one time while the device meets the trigger condition.  The action as well.  There will not be a repeat unless you are using the alert escalation to fire continuously after xx time.  Granted, if you also have the option to prevent the action if the alert has been acknowledged, that could play a factor in things as well. 

                       

                      By design, the alert is doing what it should.  Device meets condition, trigger, fire action, hold in trigger state (not re-firing actions). 

                       

                      With the alert escalation option of Execute this action repeatedly while the Alert is Triggered you can set the email to re-fire as long as the device still meets the trigger criteria.  Just make sure the Do Not Execute this action if the alert has been acknowledged is check.  Otherwise once the alert is acknowledged, no actions.  It will just be seen on the Alerts tab and the Active Alerts resource until it resets. 

                    • Re: CPU Alert only fires once
                      mharvey

                      I would look into what janene16 is referencing as well, remove the check from the option Do Not Execute this Action if the Alert is Acknowledged.