6 Replies Latest reply on Nov 10, 2016 12:59 PM by wangler@trinityrocks.com

    How to change ports used?

    aaron22

      I'm trying to set Web Helpdesk to use port 80 instead of 8081, but I must be missing a step.  I've already changed the whd.conf to use the DEFAULT_PORT=80 and restarted the WebHelpdesk service, but it keeps using port 8081.  Is there something else I need to change for this to take effect?

        • Re: How to change ports used?
          conners

          You need to use the whd_stop.bat and whd_start.bat files in the Web Help Desk directory making sure to right click run as administrator,

          as restarting the service will not read the config files.

          2 of 2 people found this helpful
            • Re: How to change ports used?
              aaron22

              Thanks, the start and stop bat files are now allowing it to change the ports being used, however when I do this I now get the following error message:

              Port 80 Error.JPG

               

              I can change to any other port and the page loads fine on the new port, but I get the above erro when trying to set it as port 80.  I'm thinking it's an IIS issue and if I look in the list of IIS sites there is "Default Web Site" using port 80, plus also Solarwinds NetPerfMon on 8787 for Orion, and WSUS Administration on 8530.  I don't know a lot about IIS, but is this basically a conflict with the "Default Web Site" already in IIS?  Do I need to manually add a site for Web Help Desk to allow it to use port 80?

                • Re: How to change ports used?
                  matt8

                  Stop the default web site or change the bindings to another port.  If you aren't using it, I'd just hit Stop in IIS on the default website and then restart WHD.  This definitely appears to be the problem.

                    • Re: How to change ports used?
                      aaron22

                      I had tried that before but I guess I didn't wait long enough for WHD to refresh fully.  Initially it went to the IIS standard page you get when IIS is running but nothing setup, but after about a minute I refreshed and now it's working. 

                       

                      I'm guessing if the server reboots that the Default Web Site in IIS will start again, would it be safe to delete this site?  Would it be better to simply delete the port 80 binding within the Default Web Site, or should I just leave this alone (I don't wanna screw it up haha)

                  • Re: How to change ports used?
                    wangler@trinityrocks.com

                    Might have been almost two years ago, but this finally resolved my multi-hour search. I was going crazy trying to figure out how to get WHD to run on port 80. I didn't know restarting the service alone wasn't enough. Sheesh!