2 Replies Latest reply on Sep 8, 2014 3:42 PM by humejo

    Disabling all Topology Layer 2 & 3 discovery from nodes

    chr@draware.dk

      A number of users have brought to my attention that the topology layer 2 and especially layer 3 discovery can cause

      quite a heavy load on some switches spiking their CPU load to 100%. Could that be true and if so how do I mass

      disable this setting from all or a select number of node please? There is a case for this on Thwack already, but

      I think it applies to an ealier version of NPM (our customer is on NPM V10.7) and I cannot find any relevant

      enties for this setting in the "Pollers" table.

       

      The suggested SQL Statement is: DELETE FROM Pollers WHERE PollerType Like 'N.Topology%'

       

      PS: I have already set the Topology interval to 1440 minutes which is the max under Polling settings.

        • Re: Disabling all Topology Layer 2 & 3 discovery from nodes
          deverts

          ,

          I'm not a SQL person and couldn't begin to assist you in disabling the topology polling as you requested. However, I have had experience with this issue in the past. I've always been able to fix the issue by upgrading the device. NPM is just polling the info it needs via SNMP, and not all devices handle this very well. But I have seen that upgrading the code on the devices normally resolves my problem most of the time. I've still had to disable topology polling on a couple device, but it is becoming more rare.

           

          You might try this, instead of disabling the polling. It is more work, but the topology data is an important component, and I'd hate to see someone miss out on this functionality.

           

          D

          1 of 1 people found this helpful
          • Re: Disabling all Topology Layer 2 & 3 discovery from nodes
            humejo

            Have you gone into "Manage Pollers", selected Layer 2 or 3, Clicked "Assign", and then just bulk selected all of the ones that are enabled and chose "Disable" yet?  If not that should be the way to do it.

             

            Jordan Hume

            Field Systems Engineer

            Loop1 Systems, Inc.

            1 of 1 people found this helpful