2 Replies Latest reply on Jul 16, 2014 11:17 AM by Craig Norborg

    UDT AD-Hoc reporting page

    Craig Norborg

      Ok, so I'm just starting to get into the UDT module, and finding it to be not as useful as we'd hoped, but maybe quite a bit of that is not knowing how it works.   Some things do puzzle me though, one being the "Ad-hoc reporting" page, it doesn't seem to work the way I would think it should. 

       

      If I go into the page initially, at the top of the screen it says "No search value specified, displaying all records for fields: IP Address, Hostname, MAC Address".   I'm not totally clear what this means.  If I go up to the search box and put in an IP, it does change to "Results containing matches for 10.17.4.6 within the following fields: IP Address, Hostname, MAC Address", which makes more sense to me.    I guess what doesn't make sense about the first one is it kinda sounds like its just displaying those 3 items, but it does those 3 plus "Connected To", "Port Number", "VLAN", "Last Seen", "First Seen".     I'm thinking it would make more sense if it just said "No search value specified - displaying all records".   And maybe near the search box, put something there that says "Searchable fields are IP Address, Hostname and MAC Address".

       

      I'm thinking it also looks as-if you can modify the searchable field.  Not sure, it just seems a bit confusing...

       

      Now, onto the big one.  Mine's been collecting data from all our DC's and quite a few switches/ports for a few days now, but this "Ad-hoc" reporting page always has just one page of stuff.  At the bottom it says "Page 1 of 1" and "Displaying results 1-50 of 13".     There are 50 items on this page, not 13.    I cannot use the page navigation arrows to go to other pages, but if I "Export as file", I get 1478 records.   I expect to see the same thing whether I'm viewing it live on the web, or exporting it to a file.   On the initial page of 50 items, none of them have the "IP Address" filled in yet, they're all blank.   But, if I click on the column header ("IP Address") to sort by it once or twice, I get the first 16 having IP addresses before it starts going into one's that don't have IP addresses.   Now, since the original 50 that showed on my screen didn't have IP addresses associated, that tells me that there is more data being hidden away here right now.

       

      To see if its a browser issue, I just opened it with a different browser.  I was using Chrome and I loaded it up with IE, getting the exact same thing...   There is a very good possibility I haven't used IE on this site since before we installed the module too...

       

      I've tried changing the filters up top, from "Direct Connections" to some of the other choices and same thing with the other fields.   I would think with "Historical Results" I would get a ton of data, but still the same results...

       

      Any ideas?