12 Replies Latest reply on Jul 2, 2014 2:54 PM by CourtesyIT

    Upgrading from 10.6 to 10.7?

    CourtesyIT

      All,

       

      I am trying to install and upgrade polling engines in my network.  When I went to do the install the Polling engines version is out of sync with my Orion NPM.  So I start looking at upgrading my NPM.

       

      I am attempting to upgrade my Orion from 10.6 to 10.7.  I have backed up my database and ready to process. I have done the following:

       

      Downloaded the new version from my License Maintenance Section

      Ran the executable NPM Full package

      Starts off fine, decompresses and issues a Backup Database request and type "YES" to continue.

      Type "YES" then begins to run.

      Finishes in less than 30 seconds

      Version remains at 10.6 according to the bottom of the screen.

       

       

      I have tried to do it with Services running or stopped, with the same result.

       

      I have to be missing something.  Probably looking at it to long.

      Thanks,

        • Re: Upgrading from 10.6 to 10.7?
          Adam Stephen

          CourtesyIT,

           

          When running the upgrade installer did you check a few things before running the installer.

           

          1.Make sure UAC is turned off

          2.Make Sure  that firewall is also off. 

          3.Please make sure you are installing with a local admin. 

          4.You will also need to run the installer as admin by right clicking and run as admin.

           

          Let me know if that helps.

           

          Adam Stephen

          Loop 1 Systems

          • Re: Upgrading from 10.6 to 10.7?
            nickzourdos

            I would consider submitting a ticket and having a rep help you via a GoToMeeting. I had all sorts of trouble when I went from 10.6 to 10.7 and ended up calling support.

            • Re: Upgrading from 10.6 to 10.7?
              CourtesyIT

              I have a ticket open with them right now and have been working with them on the issue.  The backup took a bit to get done due to server admin issues (not Solarwinds).  Just thought I would put out a word to see if anyone else had same problems and a resolution.

               

              I tried the install package again, then waited for 20 minutes for the Configuration Wizard to pop up.  No joy!  I am going to try to manual run the configuration wizard once I figure the credentials for my polling servers I have active.

              • Re: Upgrading from 10.6 to 10.7?
                CourtesyIT

                Status Update:

                 

                 

                Well, this upgrade has not gone well.

                 

                As Local Server Admin:

                I have backed up my database.

                I have downloaded the software and initiated the upgrade.  The package installer goes for about 7 seconds then quits with no error message.

                Opened a ticket with Tech Support.

                Deleted the package and rebooted server.

                Downloaded the Software package and initiated the upgrade with Tech Support on a GoTo meeting session. The package installer goes for about 7 seconds then quits with no error message.

                Ran a Diagnostic Process

                Diagnostics show that there are some Permissions being denied on the Installer Directory. Ensure directories and child folder system are given the correct permissions.

                Still no luck.  It was recommended that a Software re-install be done on the system.

                 

                Thoughts???

                 

                Observations:

                The C:\ has less than 20Gb of space

                RAM on the Server 16GB

                I have ~2200 nodes and 12,000 interfaces/Volumes/Tables managed

                 

                 

                I am looking at splitting my server into three different servers. An East Coast, Central, and West Coast to reduce the load of each server, improve reporting, and system operation. 

                • Re: Upgrading from 10.6 to 10.7?
                  d09h

                  When I've run into issues like this, host intrusion prevention software was my obstacle.  In my environments, we have to coordinate disabling this or else installations act as you have described--completely very quickly but not really installing.  HIPS logs on the server showed what was happening.  HIPS console elsewhere may have had the info as well, but nobody hovers over it looking to see what is being blocked at any moment.

                   

                  Did you ever manage to install successfully?