2 Replies Latest reply on Oct 21, 2014 1:56 PM by aLTeReGo

    AppInsight for Exchange - Throttling Policy

    joe.peterson

      I have been getting an error pulling data with AppInsight for Exchange with both Exchange 2010 and 2013. I says as follows "Fail to create a runspace because you have exceeded the maximum number of connections allowed : 18 for the policy party : MaxConcurrency. " this is part of the global policy in both exchange environment and cannot be modified.

       

      Is there a default throttling policy required for the resource account used for pulling data, also do it need to be applied the orion server as well?

       

      Thank you in advance, let me know if you need additional information.

       

      Joe

        • Re: AppInsight for Exchange - Throttling Policy
          VM Solutions

          joe.peterson this sounds like it is an Exchange ThrottlingPolicy concurrency issue, but it could also be a WinRM/WinRS powershell concurreny issue.

           

          If it is an Exchange issue, you will need to create a new throttling policy and assign it to the service account you're using for monitoring. In order to do this, the account will need to have a mailbox associated with it.

           

          Retrieve the current throttling policy:

          $policy = $null;
          $policyLink = (Get-Mailbox tonysmith).ThrottlingPolicy;
          if ($policyLink -eq $null)
          {$policy = Get-ThrottlingPolicy | ? {$_.IsDefault};}
          else
          {$policy = $policyLink | Get-ThrottlingPolicy;}


          $policy

           

          Verify the setting for PowerShellMaxConcurrency (Default policy is set to 18)

           

          Create a new throttling policy:

          New-ThrottlingPolicy -Name SolarWindsMonitoring -PowerShellMaxConcurrency 50 ;NOTE: You can put any number you feel comfortable with for your environment, but 50 should suffice for most Exchange environments

           

          Assign policy to service account:

          $NewPolicy = Get-ThrottlingPolicy "SolarWindsMonitoring"

          Set-Mailbox -Identity <Service Account> -ThrottlingPolicy $NewPolicy

           

          If you are still having issues with concurrency, then it may be a WinRM issue, and not an Exchange Throttling policy issue.

          To view your current WinRM settings, use the following command(s):

              In CLI: winrm get winrm/config/winrs

              In PS: Get-Item WSMan:\localhost\Shell\* | Select-Object Name,Value

          To modify the settings, use these commands:

              To modify MaxConcurrentUsers, type:

                    In CLI: winrm set winrm/config/winrs @{MaxConcurrentUsers = "#"}

                    In PS: Set-Item WSMan:\localhost\Shell\MaxConcurrentUsers #

              To modify MaxShellsPerUser, type:

                    In CLI: winrm set winrm/config/winrs @{MaxShellsPerUser="#"}

                    In PS: Set-Item WSMan:\localhost\Shell\MaxShellsPerUser #

           

          If this doesn't resolve your issues, aLTeReGo is your best resource at SolarWinds to answer your question.

          • Re: AppInsight for Exchange - Throttling Policy
            aLTeReGo

            I believe this issue and its resolution are outlined in the following KB article and echo tedwards recommendation.