4 Replies Latest reply on Jul 2, 2014 3:16 PM by dgglynn

    Custom Chart display bug, Gbps being rounded up and down, no decimal places available.

    dgglynn

      There is a display bug on these charts in SolarWinds.

       

      This one is displaying the wrong total throughput in the popup window, as one of these numbers should be above 1 Gbps;

       

      ord-gbps-error-remanded.jpg

       

      And this one is showing the wrong number on the Y-axis for the top mark(that mark should be higher than 1 Gbps);

       

      atl-gbps-error-remanded.jpg

       

      And this one shows you what the problem is;

       

      ord-gbps-error2-remanded.jpg

       

      The one thing all these things have in common is that the SW graph display does not have the ability to show tenths of Gbps for anything over 1 Gbps.

       

      On the first graph the second gradient marker up is marked as 2 Gbps, but assuming that it is double the first gradient(954 Mbps), it should be marked as 1.908 Gbps.

       

      On the second graph the first tick on the Y-axis is 477 Mbps, the second one is 944 Mbps, so the third should be 1.421 Gbps, but is instead marked as 1 Gbps, which is 1.421 Gbps rounded down(because it does not have the ability to display 1.4 Gbps, only 1 or 2 Gbps).

       

      And on the third one the popup shows the light blue interface as passing 2 Gbps, but in fact what is happening is that it is merely passing more than 1.5 Gbps, and is getting rounded up to 2 Gbps.

       

      Same error, of not enough significant digits(I’d settle for one more digit to give me 1.1, 1.2, 1.3 etc), on both the axis display and on the popup displaying showing statistics for specific sample.

       

      We have explained to our users the display error, so they can still get some use out of the charts, and have opened a ticket, but I thought I should pass it along because this can mess up your charts in a big way if you aren't aware of this issue.

       

      Because 1.49 Gbps does not equal 1 Gbps, and 1.51 Gbps does not equal 2 Gbps.

       

      We are running NPM 10.7, or as this bug would have it, NPM 11.