14 Replies Latest reply on May 20, 2014 5:10 PM by jsmillie2

    SMTP stopped working once upgraded to 1.1.5

    jsmillie2

      Since my alert central was upgraded to 1.1.5 i cannot send out any emails.  All my emails come into alert central and when it sends out alert central posts error when sending and i checked my network appliances and they do not see any attempt from the alert central box from even trying to send out port 25.  I wanted to downgrade but i cannot.  Is this a known issue with the new version?

        • Re: SMTP stopped working once upgraded to 1.1.5
          oleg.zastavnyi

          As a workaround you may try to specify your password and login again.

          But anyway could you send logs.? 

            • Re: SMTP stopped working once upgraded to 1.1.5
              jsmillie2

              I have specified the username and password for smtp, but the actually Alert Central box is not even sending any smtp request out.  I am tracing the communication, it will connect to the exchange server and pull all the emails, i can see this in my trace, when it runs the smtp test it does not make any request.  Also when you run the test the smtp fails instantly and does not try (all previous test if they do not work will wait a full minute before they show failure).

               

              I do not know how to pull the log files out of alert central to send to you.  If there was a way to backup my settings and i can spin up a new VM i will do that to solve the issue, currently i have soo many rules that i need to have an export / import functionality.

               

              thanks

                • Re: SMTP stopped working once upgraded to 1.1.5
                  olha.zelena

                  Hi,

                  To pull your logs you can use the next instruction Instructions for collecting Alert Central Logs

                  Yes, there's a way to backup your settings / alerts and then restore them on a new instance.

                  To Backup - you need to go to appliance (the same described in Instructions for collecting AC logs) -> SolarWinds Mgmt Tab -> Backup

                  To Restore - you need to go to appliance (the same described in Instructions for collecting AC logs) -> SolarWinds Mgmt Tab -> Browse + Restore

                  1 of 1 people found this helpful
                    • Re: Re: SMTP stopped working once upgraded to 1.1.5
                      jsmillie2

                      12:48:53.901 [NotificationQueue Listener-4] ERROR c.s.o.n.p.EmailNotificationPlugin - email sender failed to send: [AC-Assign] WS-G (4) - FAILURE - 13001 - Idris Server 2 Con... - NID[176116] to --------@----.ca (im hiding the email address in this log.

                      java.lang.NullPointerException: null

                        at java.util.Hashtable.put(Hashtable.java:432) ~[na:1.7.0_04]

                        at com.solarwinds.oncall.notification.EmailSender.getNewSession(EmailSender.java:86) ~[oncall-notification-1.1.5-SNAPSHOT.jar:na]

                        at com.solarwinds.oncall.notification.EmailSender.send(EmailSender.java:139) ~[oncall-notification-1.1.5-SNAPSHOT.jar:na]

                        at com.solarwinds.oncall.notification.plugins.EmailNotificationPlugin.notify(EmailNotificationPlugin.java:171) ~[oncall-notification-1.1.5-SNAPSHOT.jar:na]

                        at com.solarwinds.oncall.notification.NotificationMessageProcessor.processNotification(NotificationMessageProcessor.java:52) [oncall-notification-1.1.5-SNAPSHOT.jar:na]

                        at com.solarwinds.oncall.notification.NotificationMessageListener.onMessage(NotificationMessageListener.java:29) [oncall-notification-1.1.5-SNAPSHOT.jar:na]

                        at org.springframework.jms.listener.adapter.MessageListenerAdapter.onMessage(MessageListenerAdapter.java:339) [spring-jms-3.1.1.RELEASE.jar:3.1.1.RELEASE]

                        at org.springframework.jms.listener.AbstractMessageListenerContainer.doInvokeListener(AbstractMessageListenerContainer.java:537) [spring-jms-3.1.1.RELEASE.jar:3.1.1.RELEASE]

                        at org.springframework.jms.listener.AbstractMessageListenerContainer.invokeListener(AbstractMessageListenerContainer.java:497) [spring-jms-3.1.1.RELEASE.jar:3.1.1.RELEASE]

                        at org.springframework.jms.listener.AbstractMessageListenerContainer.doExecuteListener(AbstractMessageListenerContainer.java:468) [spring-jms-3.1.1.RELEASE.jar:3.1.1.RELEASE]

                        at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.doReceiveAndExecute(AbstractPollingMessageListenerContainer.java:326) [spring-jms-3.1.1.RELEASE.jar:3.1.1.RELEASE]

                        at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.receiveAndExecute(AbstractPollingMessageListenerContainer.java:264) [spring-jms-3.1.1.RELEASE.jar:3.1.1.RELEASE]

                        at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.invokeListener(DefaultMessageListenerContainer.java:1071) [spring-jms-3.1.1.RELEASE.jar:3.1.1.RELEASE]

                        at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.executeOngoingLoop(DefaultMessageListenerContainer.java:1063) [spring-jms-3.1.1.RELEASE.jar:3.1.1.RELEASE]

                        at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.run(DefaultMessageListenerContainer.java:960) [spring-jms-3.1.1.RELEASE.jar:3.1.1.RELEASE]

                        at java.lang.Thread.run(Thread.java:722) [na:1.7.0_04]

                      12:48:53.908 [WorkflowQueue Listener-1]  WARN c.s.o.w.WorkflowControllerImpl - Processing notification failure: notifId=176116, alertId=0, error=null

                      • Re: Re: SMTP stopped working once upgraded to 1.1.5
                        jsmillie2

                        AC.PNG

                        Below you can see my trace of communication between my AC box and my Exchange server,  from the bottom up, my local machine connects to AC to run this test and it contacts the exchange server, it opens up the port 143 for IMAP but it never calls or opens a port for SMTP port 25.  In my previous post above you can see that AC errors out as it cannot find the component.

                        trace.PNG

                  • Re: SMTP stopped working once upgraded to 1.1.5
                    damienball

                    I'm having this same issue as well. None of my emails are being sent out. I tried the "Getting Started" wizard again and i'm seeing the following during the SMTP test:

                     

                    DEBUG: setDebug: JavaMail version 1.4.5

                    DEBUG: getProvider() returning javax.mail.Provider[TRANSPORT,smtp,com.sun.mail.smtp.SMTPTransport,Sun Microsystems, Inc]

                    DEBUG SMTP: useEhlo true, useAuth true

                    DEBUG SMTP: useEhlo true, useAuth true

                    DEBUG SMTP: trying to connect to host "rduexchowa", port 25, isSSL false

                    220 rduexchowa.rdu.com Microsoft ESMTP MAIL Service ready at Thu, 8 May 2014 23:57:54 -0400

                    DEBUG SMTP: connected to host "rduexchowa", port: 25

                     

                    EHLO rduorionalerts.rdu.com

                    250-rduexchowa.rdu.com Hello [10.222.133.201]

                    250-SIZE 25845760

                    250-PIPELINING

                    250-DSN

                    250-ENHANCEDSTATUSCODES

                    250-STARTTLS

                    250-AUTH

                    250-8BITMIME

                    250-BINARYMIME

                    250 CHUNKING

                    DEBUG SMTP: Found extension "SIZE", arg "25845760"

                    DEBUG SMTP: Found extension "PIPELINING", arg ""

                    DEBUG SMTP: Found extension "DSN", arg ""

                    DEBUG SMTP: Found extension "ENHANCEDSTATUSCODES", arg ""

                    DEBUG SMTP: Found extension "STARTTLS", arg ""

                    DEBUG SMTP: Found extension "AUTH", arg ""

                    DEBUG SMTP: Found extension "8BITMIME", arg ""

                    DEBUG SMTP: Found extension "BINARYMIME", arg ""

                    DEBUG SMTP: Found extension "CHUNKING", arg ""

                    DEBUG SMTP: Attempt to authenticate

                    DEBUG SMTP: check mechanisms: LOGIN PLAIN DIGEST-MD5 NTLM

                    DEBUG SMTP: mechanism LOGIN not supported by server

                    DEBUG SMTP: mechanism PLAIN not supported by server

                    DEBUG SMTP: mechanism DIGEST-MD5 not supported by server

                    DEBUG SMTP: mechanism NTLM not supported by server

                    • Re: SMTP stopped working once upgraded to 1.1.5
                      andriy.trefyak

                      Hello, сould you tell me please which email server do you use?

                      I checked it on my PC and all works fine.

                      I think it's problem with configuration of your ports. Please , check which a port of smtp server uses ( secure connection / not secure connection  and number of port). And type it in field  "Outgoing SMTP Port".

                      I added screenshot below.

                      Does it help you?

                      Helpfull.pngHelpfull2.png

                      • Re: SMTP stopped working once upgraded to 1.1.5
                        nazar_hryt

                        Hi guys,

                         

                        The problem in your database, some record is null. To solve it, change ALL settings in "EMAIL SETUP" page to random values, check boxes(unchecked -> checked) and Advanced Options specially. Press "Test", it will fails. In this manner you refresh settings in BD. Go back and set right values and try again.

                        Let me know about result.

                         

                        Thanks, Nazar.