3 Replies Latest reply on Dec 7, 2016 11:39 AM by luthing

    Free TFTP server won't start on non-english OS

    blanalex

      Free TFTP Server 10.9.1.33 won't start on non-english OS. It fails with the following stack trace (in French):

       

      Le service ne peut pas être démarré. System.Net.Sockets.SocketException: Une seule utilisation de chaque adresse de socket (protocole/adresse réseau/port) est habituellement autorisée

         à System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)

         à System.Net.Sockets.Socket.Bind(EndPoint localEP)

         à System.Net.Sockets.TcpListener.Start(Int32 backlog)

         à System.Net.Sockets.TcpListener.Start()

         à System.Runtime.Remoting.Channels.ExclusiveTcpListener.Start(Boolean exclusiveAddressUse)

         à System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.StartListening(Object data)

         à System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.SetupChannel()

         à System.Runtime.Remoting.Channels.Tcp.TcpServerChannel..ctor(Int32 port)

         à TFTPServer.Service.TFTPServer..ctor()

         à TFTPServer.Service.TFTPServer.get_Current()

         à TFTPServer.Service.TFTPService.OnStop()

         à System.ServiceProcess.ServiceBase.DeferredStop()

         à System.ServiceProcess.ServiceBase.Stop()

         à TFTPServer.Service.TFTPService.OnStar...

       

      However, if I install the english language pack on the same computer, and set the systme language to english, the service starts correctly.

       

      This is with the default values:

      <root>

        <tftp-settings>

          <config>

            <AllowAllIP value="True" />

            <ReceiveOnly value="True" />

            <TransmitOnly value="True" />

            <RootDir value="c:\TFTP-Root" />

            <AutoSystemStartUp value="True" />

            <TaskTray value="True" />

            <ForceAsciiErrorMessages value="False" />

            <Timeout value="3" />

            <Retries value="6" />

            <UsedNIC value="Any" />

            <SelectedLanguage value="en-us" />

            <RenameExistingFiles value="False" />

          </config>

          <IPRanges>

          </IPRanges>

        </tftp-settings>

      </root>