3 Replies Latest reply on Sep 30, 2016 8:19 AM by tiagov2

    Issues installing NTA 4.0

    tacticaldragon

      Hello, I am using the setup where I have an NPM/NTA on one server and the NTA database on a completely separate server. I've installed the NTA4.0 on the NTA database server. After that I tried to install the NTA services on my NPM/NTA server, when it starts to configure the database at that point I get an error saying that I need to install NTA 3.8.0 or 4.0 database first. What am I doing wrong?

       

      actual error is

       

      Database configuration failed:
      Exception while configuring plugin NetFlow Traffic Analyzer component NetFlow Database. Unsopported version of NTA database. The minimum supported version of the existing NTA database is 3.8.0. Please upgrade the NTA database to version 3.8.0 to support NTA version 4.0.0 and enable configuration.

        • Re: Issues installing NTA 4.0
          tacticaldragon

          Hello Choly,

           

          You are correct. I ended up contacting support and had to run the uninstaller and try again. Once it was reinstalled everything worked fine. I ended up having another issue where the tab for NTA gave an error about the object reference is not set to instance of an object. This required me to stop the services rename the solar winds folder under inetpub, and then restart the services.

           

          Thank you very much for your help.

          1 of 1 people found this helpful
          • Re: Issues installing NTA 4.0
            choly

            I am sorry to hear you have troubles with NTA installation. The error you have quoted is most probably caused by remnants of older NTA installation (there are some old tables left in SQL DB). To solve the problem either uninstall NTA 4.0 from NPM server, temporarily install NTA 3.8.0 and upgrade it to NTA 4.0 or contact SolarWinds support, they can provide you a tool to clean the SQL DB.