2 Replies Latest reply on Mar 19, 2014 11:27 AM by afejes

    FTP Voyager - Scheduler problem

    afejes

      We have FTP Voyager 16.1.0.0 installed on a Windows 2008 R2 server. We have two automatic uploads scheduled to occur weekly (FTP Voyager establishes a connection to the destination and then moves and .CSV files from a particular directory to the destination). Once the file has been successfully moved, an email alert is generated and delivered internally.

       

      This configuration has been working fine, until Daylight savings time began on march 9th.

      Now, when the scheduled job runs, it executes continuously for an entire hour; because we receive an email alert when it runs, we know it executes about 2,600 times.

      e.g. a scheduled task that should execute one time at 0420 on tuesday is now executing once every few seconds for an hour.


      There is a line item on the release notes for 16.1.0.0 (The version we have) which states

       

      FTP client release notes for FTP Voyager.

      • Corrected a Scheduler bug where tasks created when daylight savings time is off and scheduled to run daily or at a custom interval would repeatedly run for an hour after their scheduled execution time when daylight savings time resumed.

       

      which is exactly what we're experiencing - is this a known issue / was the bug not actually corrected?

       

      Thanks!

        • Re: FTP Voyager - Scheduler problem
          dbladorn

          Let's try refreshing the job's settings.  After applying the update, adjust your job's start date/time to something else and then save it.  Then edit the job again and put back your original start/date time.

            • Re: FTP Voyager - Scheduler problem
              afejes

              Thanks for the quick reply! We are running the most recent version - the release notes state the problem we are experiencing was fixed, but it appears to not be fixed.
              We performed a clean install when we originally set this up - no upgrades or anything like that.

               

              I went ahead and changed the start date on both jobs to 3.19.2014, where DST is 'on' - we'll see if that helps.

              Thanks,