5 Replies Latest reply on Jun 4, 2014 8:46 AM by solarwindsadmin

    JVM Memory

    bpringle

      Server 2008 R2 (vmware 5.1)

       

      We have 4 techs and our current whd.config file is set up like this.

       

      MINIMUM_MEMORY=128

      MAXIMUM_MEMORY=2048

      MAXIMUM_PERM_MEMORY=128

       

      I changed the Max Mem from 526 because it was constantly maxing out.

      After changing it and restarting that server it looks like this

       

      JVM Memory.JPG

       

      Actually has gone up a little.  Why isn't it showing the new 2048 and what can I do to better manage this?

       

      Thanks for any insight.

       

       

       

      Edit:  Figured out that you have to Stop and Start WHD as Administrator for it to take.

        • Re: JVM Memory
          typhoon87

          I see in your edit you figured it out.

           

           

          Also make sure you have updated to V12. As they updated the version of Java from I believe Java 6U12 to 6U26 and it to be better.

          1 of 1 people found this helpful
          • Re: JVM Memory
            solarwindsadmin

            We have tried to changes these settings and we can't get them to work.

            We have restarted the services and rebooted the server but it still looks like it is using the default memory settings.

             

            We are going to reboot the server every couple of days until we can get this fixed.

              • Re: JVM Memory
                kylejb007

                Java is a memory leaker! We created a Scheduled Task on the server (windows) to restart whd nightly. No more slowness after a few days of usage.

                 

                Allow to run whether user is logged in or not

                Run with highest privileges

                Triggers: Daily - 1 AM every day

                Action: Start a Program:  "??:\Program Files\WebHelpDesk\whd.bat"

                Arguments: restart

                 

                This will stop WHD Service and restart it, freeing up the Memory usage.

                 

                Hope this helps!

                1 of 1 people found this helpful