1 Reply Latest reply on Jan 22, 2014 11:11 AM by sean.martinez

    SNMPv3 Cisco Routers - not show interfaces

    jchromcik

      I have configured a cisco router (3945) for SNMPv3 with the following commands:

       

      snmp-server group GROUP_NMS v3 priv read VIEW_NMS write GROUP_NMS

      snmp-server view VIEW_NMS internet included

      snmp-server user USER_NMS GROUP_NMS v3 auth md5 <password> priv AES128 <password> access LIST_NMS

      ip access-list standard LIST_NMS

      permit 172.24.0.50

       

      I get a successful test when I setup the node with the credentials.

       

      However I do not get any interfaces listed for the device, I do get all the IPAs and the SNMP information but no interfaces.

      Here is my setup of my SNMP for my node:

       

      Capture.JPG

      If I enable "debug snmp detail"  I get the following entries on my router:

       

      process_mgmt_req_int: UDP packet being de-queued

      SrParseV3SnmpMessage: No matching Engine ID.

      SrParseV3SnmpMessage: Failed.

      SrDoSnmp: authentication failure, Unknown Engine ID

       

      process_mgmt_req_int: UDP packet being de-queued

      SrParseV3SnmpMessage: Failed.

      SrDoSnmp: received get pdu

      CheckClassMIBView: all included

      CheckMIBView: OID is in MIB view.

       

      process_mgmt_req_int: UDP packet being de-queued

      SrParseV3SnmpMessage: No matching Engine ID.

      SrParseV3SnmpMessage: Failed.

      SrDoSnmp: authentication failure, Unknown Engine ID

       

      process_mgmt_req_int: UDP packet being de-queued

      SrParseV3SnmpMessage: Failed.

      SrDoSnmp: received get pdu

      CheckClassMIBView: all included

      CheckMIBView: OID is in MIB view.

       

      My router IOS version is "c3900e-universalk9-mz.SPA.152-2.T.bin"