3 Replies Latest reply on Dec 30, 2013 8:30 AM by jamie_p

    Applicability rule trouble with custom LEM agent package

    jamie_p

      The end goal here is to have a package that will install the Log & Event Manager Agent on any machine that doesn't currently have the agent.  My package successfully installs the agent and returns a success but I can't seem to get the applicability rule working to prevent installs on systems already containing the LEM agent.

       

      I have tried using the File Version rule below but it still installs on machines containing the agent.  (I got the version of 14.0.0.0 from windows going to properties > details tab on the LEM agent exe)

      file version check.png

       

      Also tried using the NOT File Exists rule with a full hard coded path and also tried common path variables.

      file exists check.png

       

       

      And my last option was to try a registry key exists rule but I am running into a parsing error with the path due to it containing the '&' character.  Here is the full registry path I need to check for HKEY_LOCAL_MACHINE\software\wow6432node\microsoft\windows\currentversion\uninstall\solarwinds log & event manager agent.  I am very new to Patch Manager but have noticed nearly all of the catalog packages always use registry checks and I am starting to see why since the only custom packages I have been able to get working right have been with registry not file exist rules. 

        • Re: Applicability rule trouble with custom LEM agent package
          jamie_p

          So after some more research into the registry key exists rule I was able to get past the xml parsing error by using & in place of the & character in the path name.  I have also used the PowerShell command Test-Path to verify my registry key (HKEY_LOCAL_MACHINE\software\wow6432node\microsoft\windows\currentversion\uninstall\solarwinds log & event manager agent) actually exists when LEM agent is installed, but the package is still just installing over and over.

          Registry Key Exists check.png

          On a side note my Installed rules seem to be working fine using either the registry key exist or file exist since my package is detecting machines that already have the LEM agent installed.  Maybe my use of the NOT rule is the issue?