5 Replies Latest reply on Dec 8, 2013 10:45 PM by superfly99

    Utilization Alerts Will Not Repeat (Not Resetting?)

    wolitski-w

      Ultimate goal: Monitor all the switch ports (interfaces) in our network that connect to our MPLS WAN service to assess WAN utilization metrics.

      Trigger Condition

      Trigger Alert when any of the following apply

           Interface ID is equal to 1     {I wish I could add a comment here so I know what '1' refers to}

           Interface ID is equal to 161

           Interface ID is equal to 219

           Interface ID is equal to 216

           Trigger Alert when all of the following apply

                Average Xmit-Recv Percent Utilization is greater than 90

      Do not trigger this action until condition exists for more than 1 seconds

      Reset Condition

      Same as above except Utilization is less than or equal to 90

      Do not reset this action until condition exists for more than 10 minutes

      Trigger Actions

      Send E-Mail...

      General

      Alert Evaluation Frequency: Check this Alert every 1 minutes

       

      To test this Alert I tried ridiculously low numbers, but I wasn't getting the results I expected/wanted, so I decomposed it into 1 simple alert to no avail.

      PROBLEM: I provide unrealistic threshold values just to test functionality but I only receive 1 email alert notification after I initially enable the Alert.

       

      I decomposed 'Average Xmit-Recv Percent Utilization' to 'Recv Percent Utilization' and set the value to a ridiculous value of 1

      The trigger condition must exist for more than 1 minute

      The Reset Condition is set to the basic 'Reset when trigger conditions are no longer true'

      The Alert is checked every 1 minute

      Trigger actions: Send me an email (that contains...)

           Interface Full Name

           InPercentUtil

           AlertTriggerTime

           AlertTriggerCount {This inserted just to test if consecutive alerts triggered}

       

      I'm expecting to receive a continuous flow of email traffic, but I'm not - why not? Your advice, suggestions, comments, shared misery is welcome!

      Theories:

      1. The utilization value reported is a snapshot in time and not a calculated valued based over a period of time

      2. There is a relationship to the polling interval that I'm not considering

        • Re: Utilization Alerts Will Not Repeat (Not Resetting?)
          wanine39

          hi

           

          do you use a Cisco rtr?  if so, have you set this

          snmp-server ifindex persist

           

          this ensures that all MIB  indexes stay constant  even over a restart

          if you don't do this, i wonder if your indexes are changing on you

           

          if yes, i think that it is bug/coding error from solarwinds

           

          i also set an alias to

          sh snmp mib ifmib ifindex

          • Re: Utilization Alerts Will Not Repeat (Not Resetting?)
            superfly99

            Change this bit

            " Average Xmit-Recv Percent Utilization is greater than 90"

            to

            "Recv Percent Utilisation is greater than 90."

             

            Make sure Type of Property to Monitor is set to Interface.

             

            Also, I would set this "Do not trigger this action until condition exists for more than 1 seconds" a little higher. You're checking the alert every 1 minute. Then once you do trigger an alert, it will take 10 mins to reset provided it's continously below the threshold you've set. If you want to clear a triggered alert, just go to View and select Active Alerts. And just click on the X for the alert you wish to clear.

            And instead of using Interface ID, you could use Inteface Caption and set a description on the interface. Or you could use Internal Interface Name where you can give it the Gi3/45 as the variable for example. These 2 options are a bit more descriptive than the Interface ID.

            1 of 1 people found this helpful
              • Re: Utilization Alerts Will Not Repeat (Not Resetting?)
                wolitski-w

                Some good tips in your response - thank you. You have made 3 points...

                1. Ultimately I do want to know when my service lines are pushing the limits and reducing it down to only received data, only tells half the story

                2. I will set all values to 1 minute and monitor the results

                3. While I am testing, I am not sharing the alert with SolarWinds Products (last tab) so I do not expect to see anything there

                4. Good tip on the the Interface_Caption and Internal_Interface_Name for a more descriptive but shorter label