5 Replies Latest reply on Oct 19, 2017 5:19 PM by mesverrum

    Netflow on Cisco 2960X switches

    blittrell

      Hi All,

       

      We have some 2960X switches that now support netflow light, however on our NTA we are not seeing the data from that.  What I am getting instead is NetFlow Receiver Service [XXXXX] received an invalid V9 template with ID 256 from device.

       

      I am guessing I am missing something on the Cisco config, it is not sending something that solarwinds needs.

       

      Has anyone configured this that can give me a sample config?

       

      Thanks

        • Re: Netflow on Cisco 2960X switches
          Martin.Krivanek

          Hi,

           

          Unfortunately I don't have experience with that particular model. But in case you've missed it, here the list of required NetFlow v9 fields for NTA. You can check the fields presence via WireShark. Also, here' s guide for configuring other Catalyst switches. Maybe it can help configuring your model also.

           

          Regards,

          Martin

            • Re: Netflow on Cisco 2960X switches
              blittrell

              Thanks for the suggestion Martin,

               

              The weird thing is it appears to be taking in information now, did not change anything on my side.  I am guessing that the error does not prevent SW from displaying what it know.  Just to see if it gets rid of the error I added the flow exporter the options for sampler table and exporter-stats, not sure what those are but maybe that will satisfy SW.  I did not see any matrix that defined the options in SW to commands in Cisco, so kind of guessing at the moment.  If the event goes away I will update the thread so we know the options worked.

                • Re: Netflow on Cisco 2960X switches
                  Martin.Krivanek

                  The event was shown because there was no valid template to accept flows from given node. Maybe the valid template arrived later and caused subsequent flows to be processed just fine. It's recommended to have flow templates export interval set to 1-minute. The event won't go away, if the issue is fixed, it simply won't appear again (after you click reset notifications).

                   

                  Regards,

                  Martin

                  • Re: Netflow on Cisco 2960X switches
                    tjarrin

                    Hi,

                     

                    So the problem was solved ? . Look, im trying to do the exactly same thing but Orion doesnt recognize my device yet. How long did it take before the solution?

                      • Re: Netflow on Cisco 2960X switches
                        mesverrum

                        Assuming your template matches the KB martin mentioned above it normally sends the template every few minutes and then everything sorts itself out automatically.  If it has been more than 15 minutes and nothing is showing up on your device I would assume the template or config is incorrect in some way.  Best way to verify at that point is to take a wireshark for a bit on the solarwinds server and double check the incoming netflow packets.