4 Replies Latest reply on Oct 10, 2013 12:49 PM by fcpsolaradmin

    Invalid certificate

    fcpsolaradmin

      Hi all-

       

      #1. I am hoping someone can help me resolve this certificate error. when clicking the dashboard tab under virtualization in Orion:

       

      Capture.PNG

       

      I have installed the cert multiple times, both on my workstation and server and still get this message. After closing the browser and reopening it I have to do the process over again.

       

      #2 Is there a way to pass login from orion to Virtualization Manager so we wont have to log in twice?

        • Re: Invalid certificate
          lukas.cerny

          Hello,

           

          #1) unfortunately, the behavior related to certificate exceptions is different for each browser. In Firefox, you can check the "Store this exception permanently" and it will remember this setting even after reopening the browser. However, Internet Explorer and Chrome will remember the exception only for the current browser session. There are two ways how to deal with this permanently (you can choose one which is more acceptable for you):

          A.) Installing valid trusted certificate to VMan

          In order to install valid trusted certificate to VMan follow these steps:

          1. Get or create a valid security certificate
          2. Go through steps in KB http://knowledgebase.solarwinds.com/kb/questions/4397/Adding+an+SSL+Certificate+to+Virtualization+Manager in chapter "To add a certificate from a certificate authority"

           

           

          B.) Disabling use of HTTPS for the embedded views

          To disable use of the HTTPS protocol for the embedded views do the following:

          1. Open the Database Manager tool on the main Orion server
          2. Click on the Add default server
          3. In the Orion database (by default SolarWindsOrion) find the WebSettings table and double click on it
          4. Execute the query and find record where SettingName=VManWebsiteUrl
          5. Edit this row and change protocol from https:// to  http:// and also port number (with default settings you should change it from 443 to 80)
          6. Save the changes

          After performing the above steps the embedded view should be loaded without use of SSL upon reloading page.

           

          #2) After resolving the issue with SSL certificates you should be logged to the embedded view automatically. If it doesn't work for you check that you have allowed third party cookies in your browser.

           

          Let me know if you have any questions.

           

          Lukas

            • Re: Invalid certificate
              bmrad

              For the third party cookies, there is more information here:

              SolarWinds Knowledge Base :: VMan Loading Error in Orion Web Console

              • Re: Invalid certificate
                fcpsolaradmin

                Thank you for your help, i ended up just changing it to http and port 80. Is the information you provided in the documentation somewhere?

                 

                 

                THought it worked but now its telling me it can not connec ton port 80

                 

                Message was edited by: FCP Monitoring

                • Re: Invalid certificate
                  fcpsolaradmin

                  lukas.cerny wrote:

                   

                  Hello,

                   

                  #1) unfortunately, the behavior related to certificate exceptions is different for each browser. In Firefox, you can check the "Store this exception permanently" and it will remember this setting even after reopening the browser. However, Internet Explorer and Chrome will remember the exception only for the current browser session. There are two ways how to deal with this permanently (you can choose one which is more acceptable for you):

                  A.) Installing valid trusted certificate to VMan

                  In order to install valid trusted certificate to VMan follow these steps:

                  1. Get or create a valid security certificate
                  2. Go through steps in KB http://knowledgebase.solarwinds.com/kb/questions/4397/Adding+an+SSL+Certificate+to+Virtualization+Manager in chapter "To add a certificate from a certificate authority"

                   

                   

                  B.) Disabling use of HTTPS for the embedded views

                  To disable use of the HTTPS protocol for the embedded views do the following:

                  1. Open the Database Manager tool on the main Orion server
                  2. Click on the Add default server
                  3. In the Orion database (by default SolarWindsOrion) find the WebSettings table and double click on it
                  4. Execute the query and find record where SettingName=VManWebsiteUrl
                  5. Edit this row and change protocol from https:// to  http:// and also port number (with default settings you should change it from 443 to 80)
                  6. Save the changes

                  After performing the above steps the embedded view should be loaded without use of SSL upon reloading page.

                   

                  #2) After resolving the issue with SSL certificates you should be logged to the embedded view automatically. If it doesn't work for you check that you have allowed third party cookies in your browser.

                   

                  Let me know if you have any questions.

                   

                  Lukas

                  Option B works if you leave the port at 443 just change the url to http://

                   

                  Thanks all for your help