5 Replies Latest reply on Sep 25, 2013 5:33 AM by roman.tatar

    How to create a custom poller for Interface Number and VlanID on Cisco Switches

    mikeyjay

      I need to create a custom poller to display Interface numbers and the vlanID for those interfaces.

       

      I create the following poller, see picture below.

      poller1.PNG

       

      Switch output:

      Gi1/0/1                      connected    trunk      a-full a-1000 10/100/1000BaseTX <-------The poller misses the trunk, expected.

      Gi1/0/2                      notconnect   2            auto   auto 10/100/1000BaseTX

      Gi1/0/3                      notconnect   2            auto   auto 10/100/1000BaseTX  <--------The poller doesn't display

      Gi1/0/4                      connected    2          a-full a-1000 10/100/1000BaseTX

      Gi1/0/5                      notconnect   2            auto   auto 10/100/1000BaseTX

      Gi1/0/6                      notconnect   1            auto   auto 10/100/1000BaseTX  <------The poller doesn't display

      Gi1/0/7                      notconnect   2            auto   auto 10/100/1000BaseTX

      Gi1/0/8                      notconnect   1            auto   auto 10/100/1000BaseTX

      Gi1/0/9                      notconnect   1            auto   auto 10/100/1000BaseTX

      Gi1/0/10                     notconnect   1            auto   auto 10/100/1000BaseTX

      Gi1/0/11                     notconnect   1            auto   auto 10/100/1000BaseTX

       

       

      I am not sure why the poller doesn't display G1/0/3 and G1/0/6?

       

      Also how would I make the output display the interface number on my Orion webpage insteald of the RowID 101102?

       

      Thanks

        • Re: How to create a custom poller for Interface Number and VlanID on Cisco Switches
          mikeyjay

          To answer my first question.  Those ports are configured as dot1q trunks.

           

          interface GigabitEthernet1/0/3

          switchport access vlan 2

          switchport trunk encapsulation dot1q

          switchport mode trunk

          spanning-tree portfast

           

          interface GigabitEthernet1/0/6

          switchport trunk encapsulation dot1q

          switchport mode trunk

           

           

          I just need to know how to make the rowID, the first column show up as an interface ID.

          poller2.PNG

          So like 10102 ----------------> to G1/0/2 or something more descripitive.

            • Re: How to create a custom poller for Interface Number and VlanID on Cisco Switches
              roman.tatar

              Hi,

              in Universal Device Poller application you may configure label for column...

              - During creating UnDP in step "Label the Rows in Your table"

              - Or right click on already created poller and select "Label".

               

              1. Try "interface names for Orion", it worked for me for vmVlan (1.3.6.1.4.1.9.9.68.1.2.2.1.2).

              2. There is also second option "use labels for table column", but it has limitation only to take labels from table from where OID is polled.

              3. Third option "use a custom label" can add custom static text.

               

              There is also another option how to assign label.

              - Create new UnDP for example to ifSpeed (1.3.6.1.2.1.2.2.1.5)

              - Set the same polling interval as vmVlan poller. Keep historical data - no.

              - Assign it to the same nodes as vmVlan poller.

              - "use labels for table column" - select ifDescr

              - Select Yes to shown on Orion web - Check in Table column - Node Details - Sumrary row - for example.

               

              When you will have new table with correct interface names click Edit in "Node Tabular Universal Device Poller" with vmVlan.

              - Scroll down and in section "Select the poller from which labels are taken" select ifSpeed poller.

              - Select Submit.

               

              Roman

              1 of 1 people found this helpful
                • Re: How to create a custom poller for Interface Number and VlanID on Cisco Switches
                  mikeyjay

                  1. Try "interface names for Orion", it worked for me for vmVlan (1.3.6.1.4.1.9.9.68.1.2.2.1.2).

                  ----This option won't work for me.  I don't have orion monitor all interfaces, I just have Orion monitor UP-Links (Trunks).


                  • Re: How to create a custom poller for Interface Number and VlanID on Cisco Switches
                    mikeyjay

                    Does anyone know of a way to remove the labels that I have around with red boxes in the screenshot below?

                    Also is there a way to pars out just the vlain-ID instead of the number 1 and then the vlan-id?

                    instead of "1.254" I would like just "254" etc.

                     

                    Mib Name: CISCO-VTP-MIB:vtpVlanName

                    The OID: 1.3.6.1.4.1.9.9.46.1.3.1.1.4

                    Description: The name of this VLAN. This name is used as the ELAN-name for an ATM LAN-Emulation segment of this VLAN.

                     

                    poller6.PNG

                      • Re: How to create a custom poller for Interface Number and VlanID on Cisco Switches
                        roman.tatar

                        Hi,

                        I think removing label is not possible. I haven't found any way how to do it.

                        It is not possible to parse label colum. In this case you have UnDP for vtpVlanName and the "1.1" label is RowID from MIB table.

                         

                        You may try to open Universal Device Poller application.

                        - Right click on "vtpVlanName" poller and select "Label".

                        - Select "use labels for table column".

                        - Select the device that you want to test it on - Vendor, Cisco, YourDevice and click "Test" button.

                        - It may take a minute so whole vtpVlanTable is loaded.

                        - From loaded values check if there is any column containing labels like you vant. (From your example 1, 2, 3, 4, 5, 9, 254, ...)

                        - If you will find suitable column select it and click "Finish".

                         

                        I believe it might be "vtpVlanIndex" or "vtpVlanIfIndex", but it was not supported on my device, so I couldn't test it.

                         

                        Roman