1 Reply Latest reply on Sep 5, 2013 9:59 AM by smason@mt.gov

    Question on FTP Voyager use with Serv-U

    smason@mt.gov

      Hello,

       

      We are trying to set up FTP Voyager for use with Serv-U. The scenario is this: we want to have a user set up in Serv-U so that when they log in and upload a file FTP Voyager is invoked via command line to move a file to another system (lileky the file that was uploaded). The problem is that we cannot seem to get FTP Voyager to actually work as intended even removing Serv-U from the equation.

       

      According to KB article #1140 this is the command line to invoke FTP Voyager:

       

      "C:\Program Files\RhinoSoft\FTP Voyager\FTPVoyager.exe" profile="Personal Site.My Site" put=C:\file.txt

       

      I get Voyager to come up and it does log into the profile just fine because we see the user's remote folder structure however the "put" command does not work, regardless of how it is invoked. We have tried a number of command line structures including how it is actually invocked in Serv-U which looked like this in the logs:

       

      Event: FILE_UPLOAD (mtintdev file upload); Type: EXECUTE; Path "C:\Program Files\RhinoSoft\FTP Voyager\FTP Voyager.exe"; Parameters "profile="TESTDEVORA" put="Q:\DEV\files\testuser\testfile.txt"

       

      (In the user event we actually use these parameters: profile="TESTDEVORA" put=$LocalPathName so that it goes to the file that was just uploaded but that's beside the point right now.)

       

      If this is put in the command window:

       

      "C:\Program Files\RhinoSoft\FTP Voyager\FTP Voyager.exe" profile=TESTDEVORA put=Q:\DEV\files\testuser\testfile.txt

       

      Voyager loads, we get the remote folder but nothign else happens. It's as if the "put" command is not recognized. Anyone else have this issue? Suggestions?

        • Re: Question on FTP Voyager use with Serv-U
          smason@mt.gov

          Tried to edit but didn't seem to take...

           

          I tried to go a "get" with the same proifile and got a path error so I managed to fix it to where it worked. However a "put" doesn't seem to do anythign at all, it just gives a folder listing and stops:

           

          COMMAND> SSH_FXP_OPENDIR: path: /u00/home/batch/prod/files

          SSH_FXP_HANDLE: handle: 0x00000000

          SSH_FXP_STATUS: status: SSH_FX_EOF; description: End of file

          COMMAND> SSH_FXP_CLOSE: handle: 0x00000000

          SSH_FXP_STATUS: status: SSH_FX_OK; description: Success

          STATUS> Listing complete: /u00/home/batch/prod/files

           

          Any idea why "put" would not work?