15 Replies Latest reply on Jan 31, 2014 5:16 AM by tonybarrett

    Not all Hostnames and IPs showing, only MAC address

    mikemartinez

      2I have just installed UDT and can only see some IP Addresses and hostnames.  I can only see the IP addresses and hostnames on one vlan.  What do I need to do to get the IP addresses and hostnames to show up for devices on all the different vlans?  I am running UDT 2.0.0.  Yes I know that version is old, but our maintenance expired.

       

      Capture.PNG

        • Re: Not all Hostnames and IPs showing, only MAC address
          bluefunelemental

          if you feel that these IP's and hostnames should be available by checking your arp tables then you might be running into a known bug in UDT 2. I believe it was 2.5.1 that resolved it ?

          • Re: Not all Hostnames and IPs showing, only MAC address
            mikemartinez

            I renewed our maintenance and successfully upgraded to 3.0.1, but I am still having the same problems.  Our gateway is a Cisco ASA.  Has anyone been able to UDT to successfully the ARP table from one of these?  From everything I can find, it looks like UDT can not pull the arp table from an ASA.  Any help would be greatly appreciated.

            • Re: Not all Hostnames and IPs showing, only MAC address
              shawn_b

              I had this problem with my UDT and DELL switches when my network was flat - all nodes and endpoints in the default vlan (vlan1).

               

              Only the devices that had static IP addresses were shoeing up in my UDT.

               

              I raised a ticket with SW support and DELL support and the following were their responses:

               

              SW - UDT isn't finding any ARP entries on my switches to retrieve the IP Addresses, thus it cannot report on what it isn't finding.

              DELL - there is no routing on my network, so the ARP tables do not have any entries.

               

              Together these explanations complemented each other, but didn't make any sense to me as the network was working, all communication between devices was happening, so there MUST have been ARP caching on the switches - switches at layer 2 utilize ARP to forward packets to their destination.

               

              However, I have since upgraded my network to include layer 3 functionality on all my DELL PowerConnect switches and guess what . . . the UDT tables are populated with the info for most ports - hostname, IP address and MAC address. Hostnames are obtained from DNS resolution of the IP address.

               

              Some devices still do not show up with IP addresses e.g. printers and other IP enabled devices, but these are not registered on my DNS servers as they have static addresses.

               

              SO it is an improvement, but still not all the way there.

              • Re: Not all Hostnames and IPs showing, only MAC address
                tonybarrett

                Think we have the same problem here. Layer 2 network with HP Procurve 2530G switches. We have an untagged VLAN (1) that all client traffic goes over, and a tagged VLAN (200) for all management traffic. UDT is polling the switches on the management network. There's no route between the management and client VLAN's, but obviously the switches are learning the client MAC's on the switch ports. So, in UDT 3.0.2, I'm getting correct port assignments (with hostnames) for our NMS's in the management VLAN, but clients just show the MAC addresses and no hostnames.

                 

                So, what would be the quick solution to fix this?

                  • Re: Not all Hostnames and IPs showing, only MAC address
                    alabama

                    I have narrowed my issue to only devices performing Layer 3 functionality running Cisco IOS 15.x and higher. I have tried moving down from SNMPv3 on these devices to SNMPv2 with the same result. Performing a UDT compatibility checker test on the 15.x yields a failure in the SNMP queries. Performing the same check on a device with the same configuration running 12.2 Cisco IOS yields good results. Opened a Ticket with Solar Winds and Solar Winds said to open a TAC with Cisco. Opened a TAC with Cisco and they tested with me yesterday and said it was Solar WInds. So now I am stuck in the middle. The SNMP test I performed with Cisco yesterday shows good results on the OID queries. My suspicion is the timer in Solar Winds is not long enough to complete the query in Cisco 15.x IOS. Max timer in SW is 20 seconds. With a SNMP tool I see the queries taking longer.

                     

                    Tonybarret.......I am not familiar with HP switches but if I were having that issue on a Cisco switch I would need to make sure I had a context statement for each VLAN including VLAN 1, this of course if you are running SNMPv3. If you are running SNMPv2 it should pick them up. Perhaps, if you are runnning v2, your VLAN OID query is failing. Try to use the UDT Compatibility checker against the HP switch in question and see if the VLAN query is failing. Is your HP switch providing L2 and L3 functionality? In other words does it hold the ARP cache for the devices you are not seeing populated?

                      • Re: Not all Hostnames and IPs showing, only MAC address
                        tonybarrett

                        thanks alabama. We are indeed running SNMPv3 on the 2530 switches, which is an interesting thought. Could SNMPv3 be the root cause of this? I'd already run the UDT compatibility checker against these switches, and I get a clean bill of health on them - everything shows 'Success' for SNMP Discovery and Layer2/3 discovery except cdpcache (Procurves use LLDP exclusively now). dot1qVlanCurrentTable query also shows 'success'.

                         

                        My gut feeling is that, while the switches are learning the MAC, there's no way for them to resolve ARP on the untagged VLAN. Indeed, if I query the arp cache on the switches, I see the correct arp entries for the tagged (management) VLAN, but not for the untagged (this is empty). I would assume though, that if the switches can't resolve arp, they would just go to their gateway.