2 Replies Latest reply on Aug 2, 2013 10:19 AM by derek.pryor

    SNMP with custom network device

    derek.pryor

      I am currently working to get NPM/APM to monitor a custom network device that supports a very limited SNMP agent for querying status. The agent is also running on a non-standard port. Using the iReasoning MIB browser I can read the support OIDs, so I know the agent is working.

       

      I have tried several ways[1] to have NPM/APM request data from the network device and all have failed / timed-out. Looking at the network traffic, the server is sending snmp get, get-next, and get-bulk requests (depending on what I am trying), but no response is returned. In all cases the authentication and privacy parameters in the snmp packets are missing. In addition, the requests contain empty variable-binding lists (no data is requested).

       

      I have looked at traffic to other devices that we are monitoring and the requests are fine, so I am at a loss as to what is happing in this case. Why is this happening?


      [1] I have tried using the Add Node Wizard which just says failed. I have also added the node as ICMP, changed the type to SNMP using the edit properties (and forced the save), and then used an APM SNMP Monitor component to try to query a valid OID.

       

      Our Setup:
      * Windows Server 2008 (32bit)
      * NPM 10.1.3
      * APM 4.0.1
      * SNMPv3 using DES/MD5