2 Replies Latest reply on Feb 19, 2014 8:46 AM by peter.jurgens

    Ongoing issue with DWRCS deployment...

    peter.jurgens

      I was excited to see that v10 was released today, however that excitement was short-lived after realizing that an issue I've been logging since v7 was still occurring...

       

      Here's the scenario:

       

      I have roughly a couple thousand Win7 x64 workstations spread across 7 geographical locations. The DameWare MRC Client Agent Service can be customized and packaged as an MSI, brilliant! "I can simply use GPO to deploy this application!" Think again... What has happened was that some workstations had the service installed and others did not. When applying a GPO to these workstations, there's no errors with the installation by GPO, and it has indicated that it has been successfully installed. However, now the computers that had the service already installed now DO NOT have the service after the GPO has applied, and those that did not have the service before now DO have the service installed. (Oddly, the computers that had the service before show DameWare in the Programs and Features, however the service is clearly not running and the files do not exist. I think this is something to do with the GPO so let's not focus on this part)

       

      After doing some testing, what I found was that if I run the MSI installation of the agent silently (/qn command line option), if the same version of the agent is already installed, it actually REMOVES the installation completely. What I would expect in this situation would be that it would REINSTALL the service with default configuration (or whatever custom config was set up when generating the MSI).

       

      I also tried running the MSI without any additional command line switches and when prompted to MODIFY, REPAIR or REMOVE (since the agent is already installed), I selected REPAIR and this has worked as expected. With previous versions, when selecting REPAIR, the agent was subsequently removed entirely.

       

      I have mentioned this issue on numerous occasions (answers to my queries were prompt and informational so I have no issues with support response) and I understand that it may not have been a top priority however I certainly do not think that you can recommend deployment of the agent by GPO when this serious issue with that type of deployment remains. Either fix it or advise your customers of the issue. (please, please fix it).

       

      If anything at all, I hope my post will be noted for a future hotfix!

        • Re: Ongoing issue with DWRCS deployment...
          macnugetz

          Hi Peter,

           

          Sorry for the delayed reply.  I found your previous post on the same topic in the DameWare forums here.  It's unclear to me why the original developers would claim 'by design' on this behavior as it doesn't make a whole lot of sense to uninstall if we detect the agent is already there.  We'll take a look at this.  Sorry for the headaches it has caused.

           

          -Craig

            • Re: Ongoing issue with DWRCS deployment...
              peter.jurgens

              Hi MacNugetz, I was just returning to this topic and wondered if perhaps my issue is being looked at for version 11 at least? I'm really surprised that I haven't seen anyone else mention this issue, especially as I'd assume a lot of users would use GPO to deploy the agents.

               

              I haven't entered the Beta for v11 but I'm considering it. Thanks for all your help.