8 Replies Latest reply on Nov 13, 2015 9:02 AM by aaswi

    IPAM poller installation aborts on polling engines

    mr.e

      I installed IPAM v4 on our Orion core server w/o issues.  However, when I ran the poller version of IPAM on our polling engines, it aborts.  The error message reads as follows:

       

      SolarWinds Orion IP Address Manager Polling Compatibilty is already installed. To repair this installation, use the "?Add or Remove Programs" control panel.


      I made sure that I used the correct file (i.e. SolarWinds-Orion-IPAM-v4.0-Full.exe) on our core server and also the correct file (i.e. SolarWinds-Orion-IPAM-v4.0-Poller.exe) on each of our 3 polling engines.  I recieved the same message, telling me that the polling compatibility is already installed.  However, when I check the Add/Remove Programs window for each of my polling engines, there is no trace of any SolarWinds applications with the name Compatibility or IPAM.  Any ideas?



        • Re: IPAM poller installation aborts on polling engines
          shuth

          The error message does not make it clear, but you do not need to install IPAM on your additional pollers. IPAM only runs on your primary polling engine.

           

          I had the exact same question and contacted support to verify (case 443338). The support representative also referenced a previous case (352421) stating that IPAM does not run on the additional polling engines, only on the primary.

           

          Saying that, I have no idea why there is an installation file for the poller (hence the confusion).

           

          Edit: This has been marked as correct but as Michal Hrncirik points out below, the IPAM poller executable is used to update the Orion Core services on your additional poller. If you have already upgraded/installed another module that has upgraded the Core, you will receive this message about the software already being installed.

            • Re: IPAM poller installation aborts on polling engines
              mr.e

              Shuth,

               

              Thanks for the feedback and for sharing what SolarWinds told you about this. Still, as you noted, it does not make sense that the SW developers would create an IPAM installation file for the pollers. I think we need some clarification from SolarWinds on this matter.  Also, I forgot to mention... when I launched the installation of IPAM v4 onto our main Orion core server, a window poped up which reads:

               

              For your SolarWinds installation to function, you must upgrade all additional polling engines and the web servers with the IPAM Compatibility Pack.

               

              The window does have a web link, but when I clicked on it, it seemed to be a dead link. So, again, something is very fishy about the IPAM installation.  If they don't need pollers, then I think that the SW folks need to:

               

              1. Rremove the fake "IPAM polling engine" installation file from the Customer Portal.
              2. Modify the IPAM installation, so it does not show a message that is useless and confusing.

               

              Otherwise, they need to provide clarification as to what should be done w/the IPAM polling engine installation file they posted on the site.  Else, they will keep having people getting frustrated and confused over this unnecessarily.

               

              Michal,  since you work for SolarWinds, I would also appreciate your thoguhts on this matter.  Thanks.

                • Re: IPAM poller installation aborts on polling engines
                  shuth

                  The only thing I can think of is to upgrade the Orion Core version on the additional pollers. However, there's a fairly high chance that if you have an additional poller you are running another module with the latest Core version anyway.

                    • Re: IPAM poller installation aborts on polling engines
                      mr.e

                      I opened a case w/SW tech support.  They asked me to send diagnostics file for one of our polling servers. I suspect you are right about installing IPAM only on the core server.  Still, if that is true, then hopefully SW will agree to my recommendations about removing the "fake IPAM polling install file" from the Customer Portal.  Else, I sure hope SW can provide with an explanation that makes sense about this apparent contradiction.  I will keep you posted. 

                    • Re: IPAM poller installation aborts on polling engines
                      michal.hrncirik

                      Hi guys,

                      sorry for late response.

                      what happened is actually correct behavior. And as you can see below it's really caused by installing NPM 10.5 first.

                       

                      Both NPM 10.5 and IPAM 4.0 uses new generation of Orion Core Services. For that reason, IPAM has to carry "additional poller" or "poller" installation pack that needs to be deployed on all existing APs of your SolarWinds modules. The only reason is to upgrade Orion Core Services so all modules may use latest version. If you would not upgrade it would probably stopped working.

                       

                      What you've done is you installed NPM 10.5 and AP first and then apply IPAM installation. But because APs were already updated you got that message that it's already there. But this state is fully OK and installation should work correctly.

                       

                      let me know if I missed something in your scenario.

                       

                      thanks,

                      Michal

                      1 of 1 people found this helpful
                        • Re: IPAM poller installation aborts on polling engines
                          mr.e


                          Michal,

                           

                          Although I appreciate your feedback I am not sure that I fully understand your response.  So, I will try to ask my question differently.  In which scenario would the SolarWinds-Orion-IPAM-v4.0-Poller.exe file need to be run on our existing AP's?  Clearly, it seems that I missing something here since I do not see the need for the SolarWinds-Orion-IPAM-v4.0-Poller.exe, since the installation aborts on the AP's.  I appreciate if you would endulge me, as I would like to understand this matter.  Many thanks!!!

                            • Re: IPAM poller installation aborts on polling engines
                              shuth

                              You would use the IPAM v4.0 poller on an existing AP if you were running other modules on your poller than were not using the new Core version. Michal mentioned that currently only NPM 10.5 and IPAM 4.0 uses the new Core.

                               

                              The only two scenarios I can think of that you would use the poller install is:

                              1) If you didn't have NPM at all

                              2) If you didn't want to upgrade NPM to 10.5 before upgrading or installing IPAM 4.0

                      • Re: IPAM poller installation aborts on polling engines
                        aaswi

                        This is somewhat a misnomer from SWI. It is actually not a poller for ipam.  The IPAM poller executable is used to update the Orion Core services on any additional poller(s) in your environment.  It does not extend “poller” functionality of ipam.