1 Reply Latest reply on Jun 5, 2013 6:32 PM by nicole pauls

    Error message when adding Directory Service Group

    mikesmith

      Hello,

      As I'm working through setting up a device, I keep running into this error message when trying to add a DS Group.

       

      Unable to Retrieve Group

      Unable to return: exception: class

      java.lang.ArrayIndexOutOfBoundsException: -1

       

      The first line is the title of the window.

       

      I have been able to add other DS Groups and DS Users but each time I try to add basically a Domain Users group, I get the above error.  Any help would be great.

       

      Mike

        • Re: Error message when adding Directory Service Group
          nicole pauls

          One thing to note with "Domain Users" and whatever users have set as their "Primary Group" is that those groups aren't updated like normal groups and LEM can't "see" their members with the LDAP connection we use. It's some kind of non-standard Microsoftness that isn't picked up with standard methods. That said, you shouldn't see an error, you just wouldn't see any members or updates to that group. I'll check on the error with our dev team to see if they can figure out what happened.

           

          I've seen this worked around (and worked around it myself) by re-using groups that are usually used for locations or broadcast notifications to the entire company, like "Everyone" or "All Offices" type things. If you only have lists/groups for individual offices/locations/groups, you could make one that contains those groups, so that you don't have to maintain another group but it will contain everyone.