1 Reply Latest reply on May 17, 2013 1:30 AM by arumugam

    STM and VMware Discovery

    mlinton

      Good Afternoon all,

           Storage Manager was doing quite well scanning our VM environment as well as our NetApp storage, until recently.  Something happened (not sure what) and now I can't get it to scan the VM environment (storage is still ok).

       

      I make have made a mistake when I removed all of my VM devices and readded them hoping it would force a rescan, it didn't.

       

      When I click on my VMware cluster I see the following message:  Data Collection Issue : com.tektools.kernel.config.ConfigurationException: Defined device `Devices.device1030` does not define a device class or type mapping

       

      I did some research but I was unable to find a solution.

       

      I can provide additional information if needed.

       

      Thanks,

      Mark

       

      Edit: Added image from agent status report.

       

      Capture.PNG

        • Re: STM and VMware Discovery
          arumugam

          Hi,

          Can you please open a ticket with support and we can troubleshoot it further? As a immediate work around,

           

          Select * from devices where deviceid=1030.Run this query against the storage manager database and find the device name. Go to Settings -> Manage Assignments -> Un-Assign the Device from the agent.

           

          For some reasons, the deviceid 1030 is updated with no information in the virtualization module xml which is causing this error message.

           

           

          Aru