4 Replies Latest reply on May 9, 2013 12:32 PM by chris.jeffreys

    LEM Reporting Error

    mattrvbc

      Good Morning,

       

      I seem to be experiencing a problem with the LEM reporting module. After installing the reports module, crystal reports runtime and the console when i open the reporting module and try and generate a report I get the following error.

       

      Cannot process the report query for default database. File alert.map not loaded


      Also when opening the reports module another error is produced

       

      Task Scheduler did not start

       

      Is there something I'm missing as part of the installation?

       

      Thanks

       

      Matt

       

       


        • Re: LEM Reporting Error
          maruthi.nityanandam

          Hi Matt,

           

          To run LEM Reports properly on Windows 7 and Windows Server 2008 computers, run the application as an administrator by either starting it from the context menu (Right-click > Run as administrator), or altering the application properties.

          To alter the LEM Reports application properties to always run as an administrator:

          1. Locate LEM Reports on your Desktop or in the Start menu: Start > All Programs > SolarWinds Log and Event Manager > Reports.
          2. Right-click the application shortcut, and then select Properties.
          3. Click the Compatibility tab.
          4. At the bottom, select Run this program as an administrator.
          5. Click OK.

           

          Thanks

          Maruthi

          1 of 1 people found this helpful
            • Re: LEM Reporting Error
              mattrvbc

              Hi Maruthi,

               

              This does not appear to make any difference, when  running as Administrator I get the same error messages.

               

              Task Scheduler did not start - When opening the reports application

               

              Cannot process the report query for default database. File alert.map not loaded - When trying to run the Agent Connection Status report.

               

              Regards

               

              Matt

                • Re: LEM Reporting Error
                  maruthi.nityanandam

                  Hi Matt,

                   

                  Just out of curiosity..

                   

                  1.  Are the other reports working? or Is it Just the Agent Connection Status report that is failing?

                  2.  Was this working earlier or is this the first time that you have installed and run the LEM reports console?

                  3.  Do you see a alert.map anywhere in the installed location?

                  4.  Have you tried re-installing the reports console ? To rule out the possibility of  a corrupt installation.

                   

                  --Maruthi

                  • Re: LEM Reporting Error
                    chris.jeffreys

                    Matt,

                     

                    Do you have Crystal Reports or an any other applications that use Crystal Reports on the system.  I have seen a similar alert.map error when there is a conflict between the Crystal Report Runtime engine the LEM reports console uses and other instances of Crystal Reports running on the system.

                     

                    I would recommend installing the LEM reports console on another system that does not have Crystal Reports installed to see if you get the same error.