5 Replies Latest reply on Apr 15, 2015 10:44 PM by Ssshock

    Can Not Add Printers Service

    Forrest Dean


      Anyone else having problems adding the Printers service in Mobile Admin?  I have 3 print servers.  Two printer servers are running Windows Server 2003 Standard.  The 3rd print server is running Windows Server 2008 R2 Datacenter.  I cannot add the Printers service within Mobile Admin using any of the print servers.  I get the following error message when trying to add the Printers service:

       

      Error creating work process (0). Work process exception: Original exception: Exception has been thrown by the target of an invocation. Access to the path 'C:\Program Files (x86)\SolarWinds\cache' is denied.

        • Re: Can Not Add Printers Service
          dsbalcau

          Hi Forrest,

           

          The "Error creating work process" errors from Mobile Admin are 99.9% of the time related to incorrect credentials. Are the credentials for those printer servers the same as you MA credentials? Are you using the correct domain? We've also seen WS DataCenter editions have really obtuse problems with credentials before, so I might concentrate on the WS2003 Servers first.

            • Re: Can Not Add Printers Service
              Forrest Dean

              Hi Balki,

               

              Yes, the credentials are the same.  I also just tried running other services on the WS2003 servers from Mobile Admin, and they are working fine.  I also tried adding adding the credentials to the server's local Administrators group, but that did not work.  I also created the SolarWinds folder inside Program Files (x86) and added the credentials with full control access, but that did not work either.  I even tried running the Printers service from Mobile Admin on one of my Windows 7 workstations with the same credentials, but I got the same results.

               

              I also looked through event viewer to see if any messages were logged, but there was nothing in there listed pertaining to this particular problem.

               

              EDIT:  I also wanted to note that there was no Program Files (x86) on the WS2003 server, but I was able to run the File Explorer service from within Mobile Admin and create the folders, Program Files (x86) and then the SolarWinds subfolder within it without any problems.