9 Replies Latest reply on Apr 10, 2013 12:01 PM by clausendb

    Cannot access new ipMonitor 10.7 server via HTTPS

    clausendb

      Hi all. I just installed a new ipMonitor 10.7 server. It is running on a Windows 2008 R2 virtual server. Accessing the server via http://FQDN:8080 works fine. I need to set the server up to be accessed via SSL - https://FQDN

       

      I have run the routine in ipmConfig to generate the self signed cert AND made sure that the Communications:Web Server Ports does have an entry for 0.0.0.0 / 443 / YES.

       

      When I try to access the site using https://FQDN, I get Internet Explorer cannot display webpage.

       

      Again, http://FQDN:8080 works fine.

       

      Thanks for your help Thwackers!

       

      - Dave

      dclausse@scgov.net

        • Re: Cannot access new ipMonitor 10.7 server via HTTPS
          Fodome

          Hello Dave,

           

          Chances are, IIS is already listening on port 443 (the default HTTPS port).  To verify this, simply run the following command within a CMD window:

           

          netstat /abnp tcp

           

          See what process is listening on 443.

           

          Assuming it is IIS, you will either need to stop it and restart ipMonitor or give ipMonitor a different port to listen on for HTTPS.  The latter can be done via the "Communication: Web Server Ports" section of the ipMonitor configuration utility.

           

          Hope this helps.

           

          Sincerely,

           

          Chris Foley • SolarWinds • Technical Support

          Office Hours: Mon-Fri 8AM-5PM EST 866.530.8040

          ______________________________________________

          explore our IT management solutions for:

          networks|applications|storage|virtualization|log & event

            • Re: Cannot access new ipMonitor 10.7 server via HTTPS
              clausendb

              Thanks for the quick response.

               

              IIS is not installed on the server. Also, the Windows Firewall is disabled.

               

               

              netstat /abnp tcp

               

              Active Connections

               

                Proto  Local Address          Foreign Address        State

                TCP    0.0.0.0:135            0.0.0.0:0              LISTENING

                RpcSs

              [svchost.exe]

                TCP    0.0.0.0:443            0.0.0.0:0              LISTENING

              [ipmservice.exe]

                TCP    0.0.0.0:445            0.0.0.0:0              LISTENING

              Can not obtain ownership information

                TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING

                TermService

              [svchost.exe]

                TCP    0.0.0.0:8080           0.0.0.0:0              LISTENING

              [ipmservice.exe]

                TCP    0.0.0.0:8081           0.0.0.0:0              LISTENING

               

               

              Not sure what to make of these netstat results.

            • Re: Cannot access new ipMonitor 10.7 server via HTTPS
              Fodome

              Dave,

               

              Have a look at the following file to see if it has any errors about loading the certificate:

               

              -\program files\solarwinds\ipmonitor\logs\runtime.log

               

              Another thing you can try is running ipMonitor in desktop mode and see if you can then connect.  To do this,

               

              1. Stop the ipMonitorSrv service.

              2. Open a CMD prompt.

              3. Go to the ipMonitor installation directory

              4. Type the following command and enter:

               

              ipmservice.exe -desktop

               

              ipMonitor is now running as an application, instead of as a service.

              See if you can now connect to it over HTTPS.

               

              To stop ipMonitor from running as an app, simply press Ctrl-C in the CMD window and restart the service.

               

              Sincerely,

               

              Chris Foley • SolarWinds • Technical Support

              Office Hours: Mon-Fri 8AM-5PM EST 866.530.8040

              ______________________________________________

              explore our IT management solutions for:

              networks|applications|storage|virtualization|log & event

              1 of 1 people found this helpful