3 Replies Latest reply on Mar 15, 2013 4:45 AM by Milan_Volejnik

    How to Exclude entries from "vm.heartbeat.latest:0" results

    m_hood

      Hi All,

       

      I am looking to turn off alerting for a number of our Linux VM's that do not have VMTools installed. As a result, we are receiving a large number of alerts to remind us that these VM's do not have VMTools installed.

       

      We have the majority of these VM's in a folder in vSphere, "Linux Machines" and I would like to exclude this folder. There are a handful of VM's not in this folder that I would also like to exclude so if anyone could be kind enough to let me know the syntax, I will be happy to enter these manually if that is the quickest way to do it (We have around 20 Linux VM's at present).

       

      Thanks in advance

        • Re: How to Exclude entries from "vm.heartbeat.latest:0" results
          Milan_Volejnik

          Hi Martin,

           

          there are several ways to bypass alerting for particular VMs. The only problem is to distinguish VMs that should be excluded.

           

          1) it's possible to exclude VMs from the alert by using their name. The solution is suitable when you want to exclude just several VMs. Example:

          • vm.origin:vmware AND NOT vm.toolsStatus:toolsok -vm.name:"VM_test*" -vm.name:"VM001"

           

          2) if the VMs are in a folder then you can use vm.folder attribute.

          VM_folder_attribute.PNG

          Example:

          • vm.origin:vmware AND NOT vm.toolsStatus:toolsok -vm.folder.name:"Linux Machines"

           

          3) you can also use Labels in VMAN. For further details see another Thwack thread. In VMAN Admin guide (Virtualization Manager Administrator Guide : Custom Labels) you can read more about labels.

            • Re: How to Exclude entries from "vm.heartbeat.latest:0" results
              m_hood

              Thanks for the clear response Milan

               

              I tried the second option - on the dashboard, after clicking through to the alert, I selected the "Configure" option at the bottom. On the first page, I then entered the code you wrote in the example;

               

              vm.origin:vmware AND NOT vm.toolsStatus:toolsok -vm.folder.name:"Linux Machines"

               

              Unfortunately, that opened up a new can of worms! I then had most of my VM's listed, stating that VMTools was needing attention (out of date on most VM's as we have just upgraded to vCentre 5.1 from 4.1) - I changed it back to default and now have just the Linux VM's listed again which is visually less alarming!

               

              I assume this is because your suggested script is looking for VMTools not reporting as OK, which in my case they are not. So this is expected behaviour. I will use this script once we have updated VMTools on all our VM's but that is likely to take some weeks, or even months.

               

              I suppose my options in the short term are excluding individual VM's or using labels in VMAN.

               

              Thanks again