4 Replies Latest reply on Feb 15, 2013 3:24 PM by dkeyser

    WMI invalid namespace error

    dkeyser

      I've noticed that some of our client machines are having this namespace error when attempting to install solarwinds WMI providers. I believe this is related to an issue with WMI but I'm not familiar with how to troubleshoot this.

       

      Any one else have this issue?

        • Re: WMI invalid namespace error
          Lawrence Garvin

          The error is an indication that the WMI Providers are not being installed.

           

          The reasons for the WMI Providers to fail to install are generally one of these two:

          - The option to disable automatic deployment of WMI Providers was enabled at installation. (This option can be changed on the "Settings" tab of the Managed Enterprise management group node.)

          - File Sharing has not been enabled on the target system. (The WMI Provider installer is copied to the system via the ADMIN$ share.)

           

          There are other reasons that can cause failed connections, but the existence of an "Invalid Namespace" error is a bona fide indication that WMI is working, the credential did authenticate, but that a method call to the code contained in the SolarWinds WMI Providers has failed due to the absence of the WMI Providers. The key is determining why the WMI Providers cannot be installed.

          • Re: WMI invalid namespace error
            dkeyser

            We do have the WMI providers being automatically deployed but checked the settings to be sure. We can access fileshare on the machines and varified that the admin$ share is present. This is happening over a handful of machines with different versions of Windows install on them, one being windows 2000 server.

             

            What would you suggest our next course of trouble shooting be?

            • Re: WMI invalid namespace error
              dkeyser

              Ah that's good to know. Looks like since it's only a few servers we are going to just install the WMI providers on them and call it good. Thought I suspect this will crop up again in the future.