0 Replies Latest reply on Jan 22, 2013 4:53 PM by gchaprnka

    regex doesn't work?

    gchaprnka

      Preface: I'm running a scheduled backup to synchronize a local folder with a folder on my ftp. Right now, its copying everything. I only want to copy one filetype.


      Problem: I can't seem to figure out how the regex engine works.

       

      Situation: I have an archive of many files, and I only want to backup the "raw" data with one file extension (lets call it .abcd). In the scheduler "ignore files and folders" I'm using 'match regular expression' with several variants, none that seem to work. I've tried many things...including:

       

      .*(?!\.abcd).....$

      ^.*\.(?!abcd$)[^.] $

       

      and nothing seems to be filtered out. I tried going the other way, explicitly denying the filetypes I did't want to upload

      . (xyz|qwe|txt|etc)$

       

      with similar results. In fact, the only thing I can get to work is just disallowing a single extension. Not very useful? What's the trick? Is this not really using regex? Am I totally missing something? I am testing my regex in notepad   with the regEx helper plugin, and many different things are working as I would expect there. Please advise!