3 Replies Latest reply on Jan 10, 2013 12:11 AM by rgnanda

    Permissions Error

    marcusb


      I'm relatively new to the company that I'm working for. The other day they asked me to go and add a few new devices to Kiwi Cattools, and it worked without a hitch. A day or two later, after the weekend, the server is running on filled up, leaving less than 100 MB on the drive, and seeing as this is a physical server, there is nothing I am permitted to really do about it. When I tried to log in after this point, I'm continuously greeted with an error, reading:

       

      Critical Error

       

      Standard Version 3.4.0

      Error Number: 70

      Description: Permission denied

      Module Name: MailServer.cls

      Procedure Name: FileDelete

      Line Number: 70

      Date and time : XX:XX:XX

       

      Now, when this first happened, my co-worker deleted some old logs and cleared off around 10 GB, all was fine after that. The next day we came back and we had the same issue. So he cleared out more space, only this time, we cannot get the error to cease.

       

      Things to note:

      When the drive is full, the list of devices does not populate and the error appears after approx 30 seconds.

      When the drive gets freed up a bit, the list does populate, but the error still appears after approx 30 seconds and closes the program.

      When the error pops up, the server forwards an email titled Error with schedule, with nothing in the body.

       

      Does anyone have any idea on how I can resolve this issue? Any sort of clue would help, as the error seems odd to me. It claims to be a permissions error, but yet I've already had occasions where no such error have appeared, leading me to wonder what it's trying to do.

       

      The attached file includes a screen cap of the error.

        • Re: Permissions Error
          rgnanda

          Hi Marcus,

           

          As it's showing the issue is related to "permissions"

           

          Are you protecting any folders related to CatTools in the installed location?

          If so please remove those and check.

           

          And there are some additional steps to avoid space issues,

          1.You can limit you log file sizes by getting into Options\Setup\Logging page.

          2.Avoid unnecessary mail triggers for the activities. This can be avoided in each activities E-mail tab.

          3.Also make sure that you E-mail settings are correct and all the generated mails are being sent correctly to the address given in Options\Setup\E-mail.

          4.As you are getting the issues frequently now, do,

               a)Stop CatTools from running and delete the Info log & Activity log(..\CatTools3 folder) and queued Mails(..\MailQueue folder), old Reports(..\Reports folder) ,

               Captured Datas(..\Captured Data folder), Configs(..\Configs folder) and Dated Configs(..\Dated Configs folder)

               b)Before manually deleting the above make sure you are having necessary backup of those files for your reference then delete

          5.Then Run CatTools and check

           

          And more over we are having new version as 3.8.0 as well. You can upgrade it to that if you wish and have valid license/maintenance period

           

          Please check these and let me know.

           

          Thanks,

          Nanda

          • Re: Permissions Error
            marcusb

            Thanks a bunch for the suggestion Nanda. I wound up attempting to delete the mail queue first, like suggested, since that was what was in the error message. When I attempted to delete it, I recieved a windows error saying that the files were in use by another program.

             

            I stopped the service, deleted the files, restarted the services and all is well now. Thanks for the quick response on this.