5 Replies Latest reply on Nov 5, 2012 12:22 PM by Richard Nicholson

    CISCO 3560 flexible netflow

    kiilerich

      Hi

       

      I´m trying to setup the new "Flexible Netflow" feature on a 3560G with IOS version 150-2.SE.

       

      I have followed the diff. guides on the net but so far without any luck.

       

      Do any in the forum have a working example how to setup Flexible Netflow on a 3560G?

       

      I have included my setup if.

       

       

       

      *************Config************************

      flow exporter SolarwindsNF

      description To Netflow in dkanm1

      destination <IP for NTA>

      source Vlan232

      transport udp 2055

      template data timeout 60

      !

      flow record standard

      match ipv4 tos

      match ipv4 protocol

      match ipv4 source address

      match ipv4 destination address

      match transport source-port

      match transport destination-port

      collect routing source as

      collect routing destination as

      collect routing next-hop address ipv4

      collect ipv4 id

      collect ipv4 source mask

      collect ipv4 destination mask

      collect transport tcp source-port

      collect transport tcp destination-port

      collect transport tcp flags

      collect interface input

      collect interface output

      collect flow direction

      collect counter bytes

      collect counter packets

      collect timestamp sys-uptime first

      collect timestamp sys-uptime last

      !

      flow monitor standard-Monitor

      description Default monitor

      record standard

      exporter SolarwindsNF

      cache timeout active 60

      !

      interface GigabitEthernet0/24

      description MPLS-Router

      switchport access vlan 232

      switchport mode access

      ip flow monitor standard-Monitor input

      spanning-tree portfast

      !

      ip flow monitor standard-Monitor input

      ip address 10.144.232.254 255.255.255.0

      ip helper-address 10.144.17.5

      no ip mroute-cache

      !

      interface Vlan233

      ip flow monitor standard-Monitor input

      ip address 10.144.233.254 255.255.255.0

      ip helper-address 10.144.17.5

      no ip mroute-cache

      !