3 Replies Latest reply on Oct 17, 2012 3:43 AM by Jaybed

    SSH issue

    Jaybed

      Hi

       

      I have now got version 3.8.0 up and running after initial licence issue. I have tested all of our devices and have come across some issues with Extreme Networks switches and also Cisco MDS. It just hangs at the key exchange. I saw this issue with Extreme when I tried a different wodssh.dll file with a call, (case ref 296751 ), I had opened for trying to get Cisco ACS 5 added to Cattools. Ironically version 3.8.8 now works with Cisco ACS 5.

       

      When I check C:\WINDOWS\system32 I see the following version of wodssh.dll, version 2.9.6.148 . I can't remember what version Chris had me test under that call reference.

       

      I have attached some debugs and I also used the kiwi connection analyser as well. The connection analyzer worked fine using all encryption types.

       

      Weirdly though I checked a BD 8800 and it did work, but this switch is running an older firmware, but it didn't work for an x450 running that same version. Most odd.

       

      cisco_mds_ssh2 - shows just 1 debug using SSH2 as the protocol

       

      extreme_switch_ssh2 - shows multiple debugs using all the shown Cattools SSH methods.

       

      Kiwi_conn_Analyser - shows all attempts made using this tool

       

      I'm happy to leave this running for another day but as this is our production server I will need to revert back to our previous version as it backups for all of our Extreme and Cisco MDS switches now don't work. If you want me to continue testing then I can set it up on a test server assuming I can use the same licence for this?

       

      On a good note it does work ok for , Cisco routers, Cisco VPN 3000, Cisco ASA, Juniper Netscreen and Meru controllers.

       

      Regards

       

      Jamie

        • Re: SSH issue
          Steve Welsh

          Hi Jamie,

           

          Many thanks for letting us know about this issue.  The previous version of wodssh.dll, was version 2.6.9.xxx, but that version would not work with the Cisco ACS devices due to the wodssh version not supported the ACS's SSH encryption ciphers.

          I will therefore need to investigate further as to what is going wrong now with SSH connections for the Extreme and Cisco MDS devices and come back to you.

           

          I've sent you a thwack 'Friend Request' as I may need to gather some device sensitive data from you via other means of communication (rather than in a public forum).

          Please accept the friend request and I can then email you offline.

           

          Kind regards,

           

          Steve

            • Re: SSH issue
              Jaybed

              Hi Steve

               

              I have accepted your request. I will leave it running version 3.8.0 over the weekend. I might be able to get an Extreme switch set up on our public network as I did before for Chris. Unfortunately I won't be able to do this for Cisco MDS.

               

              Regards

               

              Jamie

                • Re: SSH issue
                  Jaybed

                  Hi all

                   

                  Just thought I would post so others can see.

                   

                  The RC3 version seems to have fixed the issue with SSH to Extreme switches and Cisco MDS.

                   

                  I then tested scheduled backups to all of my devices and I came across no issues. We backup the following device types.

                   

                  Cisco ASA

                  Cisco MDS

                  Cisco VPN

                  Cisco VPN Concentrator

                  Extreme switches

                  Juniper Netscreen

                  Meru Controller

                   

                  Cheers

                   

                  Jamie