2 Replies Latest reply on Sep 25, 2012 8:58 AM by ironclad757

    Report Writer - Updated an Existing Report - Does not show the changes

    ironclad757

      I have a Network Availability report that filters to display node names that starts with Switches-. It utilizes a schedule to email this report every Sunday.

      I made a change to also display nodes that starts with Routers-.  The Preview displays correct (consist of devices that begin with Switches- and Routers-)

       

      However, the report on the orion web site only shows nodes that begin with Switches- (not the change I made last week which consist of showing Routers-).  In addition, the schedule that is setup to email the last 7 days of availability of these nodes, doesn't display the change of showing Routers- too.

       

      How do I fix this? Seems to be a problem with the report writer.  

        • Re: Report Writer - Updated an Existing Report - Does not show the changes
          Zak Kahl

          The updated report sounds like it was never saved.  Go back in and change it again, then try to save it.  And watch for any errors.  You may see an macro error about "a nonexistent field".  It will list the fields below, just add them the the "select fields" tab  Then you can go into the "field formatting" tab, select them and click on the "hidden field" so these fields won't be displayed in the report.

           

          This is one reason why the report isn't saving.

           

          Zak Kahl

          Loop1 Systems

            • Re: Report Writer - Updated an Existing Report - Does not show the changes
              ironclad757

              That is exactly what it seems like--it doesn't save.  However, within D:\Program Files (x86)\SolarWinds\Orion\Reports, it shows the report with the modified date of a few minutes ago.  I also even created a new report and then went to  http://hr-atms-nms/Orion/Report.aspx?Report=Report_Name_Here, it returns an error message:Could not find file 'D:\Program Files (x86)\SolarWinds\Orion\Reports\FolderNameHere\Report_Name_Here.OrionReport'.

               

              Ok, I see what is wrong now.  When I make changes or create a new report it saves it to \Orion\Reports.  To view it on the Orion web page, it requires the modified or new report to be copied to \Orion\Reports\FolderNameHere.

               

              Once I copied the report to the folder within /Reports/ I was able to see the changes made to the report.

               

              Thanks for your assistance.

              1 of 1 people found this helpful